Woodstock table component not showing in JEE 1.4 JSF pages.

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Oddvard Myrnes, Unassigned)

Tracking

9 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.0; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Created a Netbeans 6.5 Visual Web project with JEE 1.4. Selected Visual Web JavaServer Faces & drop a Woodstock table component onto the design pane & run.


Actual results:

The table is not shown.


Expected results:

Table should show. If you create the same project with JEE 5 it will work correctly.

Comment 1

6 years ago
Please provide a public URL or reduced test case that exhibits this issue.
(Reporter)

Comment 2

6 years ago
(In reply to Tim (fmdeveloper) from comment #1)
> Please provide a public URL or reduced test case that exhibits this issue.

Dear Tim,

Thanks for this quick answer. I will belive it is easier for you to create two test cases yourself. Do this:

1. Install Netbeans 6.5 with Tomcat 6.0.18 webappserver
   This is the last release that supported VisualWeb.
2. Create New Project.
   Select Visual Web, then select Visual Web Javafaces Framework.
   Select JEE 14 environment & create the project.
3. When the project opens, select page1 & open it in the design mode,
   choose a table component from the palette & drop it onto the pane.
4. Save it & run it.

You will see that the table component is not showing up.

If you do the same steps on a new project using JEE1.5 instead of 1.4 it will work.

Let me know if you need more assistance!

Oddvard
(Reporter)

Comment 3

6 years ago
Dear All,

The case is resolved. The fault was not in Firefox, but in the component itself. The Woodstock table component had a 'Hidden' property that was set in its theme javascript when used with NetBeans. The explanantion is in this thread: http://netbeans.org/projects/www/lists/nbusers/archive/2012-01/message/429

Issue solved. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.