Demo Studio interface allows users to navigate to hidden demos

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
5 years ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

7 years ago
At the moment, a Demo named "Orientation Indicator" exists and is marked as hidden.

Steps to reproduce:
1. Log out of the MDN.
2. Open https://developer.mozilla.org/en-US/demos/detail/orientation-tetris
3. Hit "PREV"

Expected result:
The demo "Simple Compass" is loaded. "Orientation Indicator" is skipped because it is marked as hidden.

Actual result:
The URL .../detail/orientation-indicator is loaded and a "Permission Denied" error is shown.
(Reporter)

Updated

7 years ago
Target Milestone: --- → 2.3
Saying 'nonono' to more things in favor of wiki migration work.
Component: Website → Demos
QA Contact: website → demos
Whiteboard: u= c= p= → u=user c=demos p=
Target Milestone: 2.3 → ---
(Reporter)

Comment 2

7 years ago
Understood. Thanks for pushing back on this.
(Assignee)

Updated

6 years ago
Version: MDN → unspecified
(Assignee)

Updated

6 years ago
Component: Demos → Demo Studio / Dev Derby
Product: Mozilla Developer Network → Mozilla Developer Network
(Reporter)

Updated

6 years ago
Whiteboard: u=user c=demos p= → [specification][type:bug]
(Reporter)

Comment 3

6 years ago
Replacing this with bug 839314, which provides a true specification and more up-to-date information.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(In reply to John Karahalis [:openjck] from comment #3)
> Replacing this with bug 839314, which provides a true specification and more
> up-to-date information.

Why not just comment on the original bug?
(Reporter)

Comment 5

6 years ago
Want the specification to be comment 0 for the sake of clarity, especially since comment 0 is really out of date here. I guess it might be overkill, but since the specification form (https://bugzilla-stage-tip.mozilla.org/form.mdn) creates a new bug, this is probably the workflow we're going to need to ask contributors to follow anyway if/when they want to provide more detail.
You need to log in before you can comment on or make changes to this bug.