Closed Bug 722888 Opened 9 years ago Closed 8 years ago

[multicol] insufficient invalidation after content is removed from beginning of a multicol container

Categories

(Core :: Layout, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dholbert, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached file testcase 1 (obsolete) —
STR:
 1. Load attached testcase

EXPECTED RESULTS:
 Yellow div, with only "a" visible in upper-left corner.

ACTUAL RESULTS:
 "9 0 a" is also visible, from initial rendering, until the window is fully invalidated.

NOTE: The rendering seems to depend on the exact text positioning (e.g. if I add/remove a few characters, the bug goes away) -- so it may not reproduce with this testcase on other platforms w/ different fonts.
Attached file testcase 1
(changed parentElement to parentNode in the testcase's JS, to make it load in older Firefox versions as well)
Attachment #593228 - Attachment is obsolete: true
I can repro in trunk, but not in Firefox 4 --> regression
 Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120131 Firefox/12.0a1
 Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Keywords: regression
This regressed in the last month, actually.
 Last good nightly: 2011-12-26
 First bad nightly: 2011-12-27
 Pushlog:
 http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9f29daaecbcc&tochange=6f4f2e53694b

Looks like a regression from Bug 695222.
Blocks: 695222
(In reply to Daniel Holbert [:dholbert] from comment #3)
> Looks like a regression from Bug 695222.

Yup -- I confirmed via targeted builds that
   http://hg.mozilla.org/mozilla-central/rev/93b804e5f3f5
is the first cset affected by this bug.
WFM in nightly:
 Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20130507 Firefox/23.0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Fix range:
{
Last bad nightly: 2012-09-28
First good nightly: 2012-09-29

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=895f66c4eada&tochange=c09a0c022b2e
}

That includes DLBI, which is almost certainly what fixed this.

Updating resolution to FIXED by that.
Depends on: dlbi
Resolution: WORKSFORME → FIXED
Landed a reftest made from this bug's attached testcase:
  https://hg.mozilla.org/integration/mozilla-inbound/rev/5a5e13148f9d

(w/ earlier try server sanity check: https://tbpl.mozilla.org/?tree=Try&rev=4faba653fb37 )
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.