Install OS packages on Jenkins to support building Sync Server

RESOLVED INVALID

Status

mozilla.org Graveyard
Server Operations
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: gps, Assigned: dumitru)

Tracking

Details

(Reporter)

Description

6 years ago
I'm trying to get the Sync Server Python code building on the public Jenkins server at ci.mozilla.org/. The project needs some OS packages installed to build. Unfortunately, these don't seem to be installed currently.

At this time, the build currently seems to be blocked on missing files for libevent. Please install the following packages:

  libevent libevent-devel

I anticipate multiple packages needing to be installed in the end. Please ping me after these are installed and we'll see what additional packages (if any) need to be installed.
(Assignee)

Updated

6 years ago
Assignee: server-ops → dgherman
(Assignee)

Comment 1

6 years ago
I installed libevent, but libevent-devel conflicts with compat-libevent14, which is required for memcached.

Transaction Check Error:
  file /usr/bin/event_rpcgen.py from install of libevent-devel-2.0.12-1.rhel6.x86_64 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.x86_64
  file /usr/lib64/libevent_core.a from install of libevent-devel-2.0.12-1.rhel6.x86_64 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.x86_64
  file /usr/lib64/libevent_core.so from install of libevent-devel-2.0.12-1.rhel6.x86_64 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.x86_64
  file /usr/lib64/libevent_extra.a from install of libevent-devel-2.0.12-1.rhel6.x86_64 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.x86_64
  file /usr/lib64/libevent_extra.so from install of libevent-devel-2.0.12-1.rhel6.x86_64 conflicts with file from package compat-libevent14-1.4.13-1.rhel6.x86_64
(Reporter)

Comment 2

6 years ago
Hmmm. It appears the Python gevent package requires libevent 2.x. I see memcached supports libevent 2.x, so from my perspective the ideal path would be to upgrade memcached. But, I don't want to ask for that unless I get buy-in from whoever is using memcached. Oh, dependency hell.

I could try working around this by compiling libevent 2.x as part of the local build.

Let me masticate on this.
Assignee: dgherman → gps
(Reporter)

Comment 3

6 years ago
I worked around the conflict by building libevent 2.x inside Jenkins and then reference that build from our project. Rest assured, I did not install libevent 2.x in system-wide location, so nobody should notice.

You can optionally remove the libevent package then mark this WONTFIX or WORKSFORME.
Assignee: gps → dgherman
(Assignee)

Comment 4

6 years ago
ok, thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.