Last Comment Bug 722956 - Intermittent "###!!! ASSERTION: thread pool wasn't shutdown: '!mPool'" during test_history_tracker.js and test_bookmark_store.js
: Intermittent "###!!! ASSERTION: thread pool wasn't shutdown: '!mPool'" during...
Status: RESOLVED FIXED
[qa-]
: assertion, intermittent-failure
Product: Core
Classification: Components
Component: Web Services (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: :Benjamin Peterson
:
Mentors:
: 775086 (view as bug list)
Depends on: 804479
Blocks: 438871 782272 805982
  Show dependency treegraph
 
Reported: 2012-01-31 18:46 PST by Phil Ringnalda (:philor, back in August)
Modified: 2013-01-08 23:17 PST (History)
6 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
clear io timer (1.19 KB, patch)
2012-07-12 14:14 PDT, :Benjamin Peterson
philipp: feedback+
Details | Diff | Splinter Review
clear io timer (6.80 KB, patch)
2012-07-12 15:11 PDT, :Benjamin Peterson
philipp: review+
Details | Diff | Splinter Review
clear io timer (6.63 KB, patch)
2012-07-12 15:29 PDT, :Benjamin Peterson
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor, back in August) 2012-01-31 18:46:33 PST
https://tbpl.mozilla.org/php/getParsedLog.php?id=8992100&tree=Firefox
Rev3 WINNT 6.1 mozilla-central debug test xpcshell on 2012-01-31 16:37:21 PST for push 1410782d557d

TEST-INFO | c:/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_history_tracker.js | Starting cleanup
Clean up.

TEST-INFO | (xpcshell/head.js) | test 3 pending

TEST-INFO | (xpcshell/head.js) | test 3 finished

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-INFO | (xpcshell/head.js) | test 1 finished

TEST-INFO | (xpcshell/head.js) | exiting test

TEST-PASS | (xpcshell/head.js) | 20 (+ 0) check(s) passed

TEST-INFO | (xpcshell/head.js) | 0 check(s) todo
WARNING: nsExceptionService ignoring thread destruction after shutdown: file e:/builds/moz2_slave/m-cen-w32-dbg/build/xpcom/base/nsExceptionService.cpp, line 199
###!!! ASSERTION: thread pool wasn't shutdown: '!mPool', file e:/builds/moz2_slave/m-cen-w32-dbg/build/netwerk/base/src/nsStreamTransportService.cpp, line 466
<<<<<<<
PROCESS-CRASH | c:\talos-slave\test\build\xpcshell\tests\services\sync\tests\unit\test_history_tracker.js | application crashed (minidump found)
Crash dump filename: c:\talos-slave\test\build\xpcshell\tests\services\sync\tests\unit\64f6cf58-b721-426e-8419-02b927d17402.dmp
Operating system: Windows NT
                  6.1.7600 
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_BREAKPOINT
Crash address: 0x73811277

Thread 0 (crashed)
 0  mozalloc.dll!mozalloc_abort(char const * const) [mozalloc_abort.cpp:1410782d557d : 79 + 0x0]
    eip = 0x73811277   esp = 0x0025f078   ebp = 0x0025f080   ebx = 0x04051d90
    esi = 0x6f879380   edi = 0x6f8f18b0   eax = 0x00000000   ecx = 0x30d136eb
    edx = 0x6f961d40   efl = 0x00000206
    Found by: given as instruction pointer in context
 1  xul.dll!NS_DebugBreak_P [nsDebugImpl.cpp:1410782d557d : 375 + 0xc]
    eip = 0x69960600   esp = 0x0025f088   ebp = 0x0025f4a0
    Found by: call frame info
 2  xul.dll!nsStreamTransportService::~nsStreamTransportService() [nsStreamTransportService.cpp:1410782d557d : 466 + 0x36]
    eip = 0x68d452d4   esp = 0x0025f4a8   ebp = 0x0025f4c8
    Found by: call frame info
 3  xul.dll!nsStreamTransportService::`scalar deleting destructor'(unsigned int) + 0xa
    eip = 0x68d452ea   esp = 0x0025f4c4   ebp = 0x0025f4c8
    Found by: call frame info
 4  xul.dll!nsStreamTransportService::Release() [nsStreamTransportService.cpp:1410782d557d : 490 + 0x58]
    eip = 0x68d45667   esp = 0x0025f4d0   ebp = 0x0025f4e0
    Found by: call frame info
 5  xul.dll!nsCOMPtr<nsIEventTarget>::~nsCOMPtr<nsIEventTarget>() [nsCOMPtr.h:1410782d557d : 521 + 0x5]
    eip = 0x68d356d3   esp = 0x0025f4e8   ebp = 0x0025f500   ebx = 0x03a4fec0
    Found by: call frame info
 6  xul.dll!nsAsyncStreamCopier::~nsAsyncStreamCopier() [nsAsyncStreamCopier.cpp:1410782d557d : 75 + 0x17]
    eip = 0x68d37cc4   esp = 0x0025f4f4   ebp = 0x0025f500
    Found by: call frame info
 7  xul.dll!nsAsyncStreamCopier::`vector deleting destructor'(unsigned int) + 0xa
    eip = 0x68d37f01   esp = 0x0025f4fc   ebp = 0x0025f500
    Found by: call frame info
 8  xul.dll!nsAsyncStreamCopier::Release() [nsAsyncStreamCopier.cpp:1410782d557d : 128 + 0x58]
    eip = 0x68d378c9   esp = 0x0025f508   ebp = 0x0025f518
    Found by: call frame info
 9  xul.dll!DoDeferredRelease<nsISupports *> [XPCJSRuntime.cpp:1410782d557d : 629 + 0x5]
    eip = 0x69504675   esp = 0x0025f520   ebp = 0x0025f550   ebx = 0x00000008
    Found by: call frame info
10  xul.dll!XPCJSRuntime::GCCallback(JSContext *,JSGCStatus) [XPCJSRuntime.cpp:1410782d557d : 925 + 0xa]
    eip = 0x69504bf5   esp = 0x0025f530   ebp = 0x0025f550   ebx = 0x00000000
    Found by: call frame info
11  xul.dll!jsds_GCCallbackProc [jsd_xpc.cpp:1410782d557d : 528 + 0x14]
    eip = 0x696ebd96   esp = 0x0025f558   ebp = 0x0025f564   ebx = 0x00000000
    Found by: call frame info
12  mozjs.dll!js_GC(JSContext *,JSCompartment *,JSGCInvocationKind,js::gcreason::Reason) [jsgc.cpp:1410782d557d : 3019 + 0x4]
Comment 1 Gregory Szorc [:gps] 2012-01-31 19:56:07 PST
While the error occurred in a Sync test, it looks like a network stack error to me!
Comment 2 Philipp von Weitershausen [:philikon] 2012-02-01 09:53:38 PST
Indeed, though it could be due to Sync's spinning the event loop during network requests...
Comment 3 Ed Morley [:emorley] 2012-05-25 05:21:27 PDT
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-05-24 23:05:25 PDT for push 44921eaaa4e2

slave: talos-r3-fed-043

https://tbpl.mozilla.org/php/getParsedLog.php?id=12055192&tree=Mozilla-Inbound

{
TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | [test_orphan : 333] 3 == 3

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | [test_orphan : 335] non-existent == non-existent
Clean up.
Create a bogus orphan record and write the record back to the store to trigger _reparentOrphans.
Sync.Store.Bookmarks	DEBUG	Reparenting orphans 6 to 6
WARNING: NS_ENSURE_TRUE(aItemId != aNewParent) failed: file ../../../../toolkit/components/places/nsNavBookmarks.cpp, line 1284
Sync.Store.Bookmarks	DEBUG	Failed to reparent item. Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.moveItem] Stack trace: _reparentItem()@resource:///modules/services-sync/engines/bookmarks.js:580 < resource:///modules/services-sync/engines/bookmarks.js:568 < _reparentOrphans()@resource:///modules/services-sync/engines/bookmarks.js:571 < BStore_applyIncoming()@resource:///modules/services-sync/engines/bookmarks.js:532 < <file:unknown> < test_reparentOrphans()@/home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js:356 < run_test()@/home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js:379 < _execute_test()@/home/cltbld/talos-slave/test/build/xpcshell/head.js:304 < -e:1
Verify that is has been marked as an orphan even though it couldn't be moved into itself.

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | [test_reparentOrphans : 360] dGEla_YAna4m == dGEla_YAna4m
Clean up.

TEST-INFO | (xpcshell/head.js) | test 1 finished

TEST-INFO | (xpcshell/head.js) | exiting test

TEST-PASS | (xpcshell/head.js) | 62 (+ 0) check(s) passed

TEST-INFO | (xpcshell/head.js) | 0 check(s) todo
WARNING: nsExceptionService ignoring thread destruction after shutdown: file ../../../xpcom/base/nsExceptionService.cpp, line 166
###!!! ASSERTION: thread pool wasn't shutdown: '!mPool', file ../../../../netwerk/base/src/nsStreamTransportService.cpp, line 433
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x002B066F]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x002B06FE]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0029D69C]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0029E420]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0029E46E]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0029E0FB]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x00C8677A]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0152EC31]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0152EE6D]
js::GCForReason(JSRuntime*, js::gcreason::Reason)+0x00000020 [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01502450]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x00C5985B]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0119CC88]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0119FE63]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0119FF30]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x011A00B3]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x0114F7F1]
NS_ShutdownXPCOM+0x0000001A [/home/cltbld/talos-slave/test/build/firefox/libxpcom.so +0x00001EB6]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/xpcshell +0x00008AA9]
__libc_start_main+0x000000E6 [/lib/libc.so.6 +0x00016BB6]
###!!! ASSERTION: thread pool wasn't shutdown: '!mPool', file ../../../../netwerk/base/src/nsStreamTransportService.cpp, line 433
<<<<<<<
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux-debug/1337922594/firefox-15.0a1.en-US.linux-i686.crashreporter-symbols.zip
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Crash dump filename: /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/177db81a-5004-46ea-631c032a-64793166.dmp
Operating system: Linux
                  0.0.0 Linux 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  SIGSEGV
Crash address: 0x0

Thread 0 (crashed)
 0  libmozalloc.so!TouchBadMemory [mozalloc_abort.cpp : 35 + 0x0]
    eip = 0x00265efe   esp = 0xbf9ae3b8   ebp = 0xbf9ae3d8   ebx = 0x00267188
    esi = 0x00c59844   edi = 0xbf9ae408   eax = 0x0000000a   ecx = 0x00267188
    edx = 0x00c5a32c   efl = 0x00010206
    Found by: given as instruction pointer in context
 1  libmozalloc.so!mozalloc_abort [mozalloc_abort.cpp : 56 + 0x4]
    eip = 0x00265f3f   esp = 0xbf9ae3c0   ebp = 0xbf9ae3d8   ebx = 0x00267188
    esi = 0x00c59844   edi = 0xbf9ae408
    Found by: call frame info
 2  libxul.so!NS_DebugBreak_P [nsDebugImpl.cpp : 382 + 0x5]
    eip = 0x020f0813   esp = 0xbf9ae3e0   ebp = 0xbf9ae818   ebx = 0x02cc31e8
    esi = 0xbf9b3e48   edi = 0xbf9ae408
    Found by: call frame info
 3  libxul.so!nsStreamTransportService::~nsStreamTransportService [nsStreamTransportService.cpp : 433 + 0x25]
    eip = 0x0120a66f   esp = 0xbf9ae820   ebp = 0xbf9ae848   ebx = 0x02cc31e8
    esi = 0x0991f3d8   edi = 0x00000000
    Found by: call frame info
 4  libxul.so!nsStreamTransportService::Release [nsStreamTransportService.cpp : 454 + 0x5]
    eip = 0x0120a6fe   esp = 0xbf9ae850   ebp = 0xbf9ae878   ebx = 0x02cc31e8
    esi = 0x0991f3d8   edi = 0x00000000
    Found by: call frame info
 5  libxul.so!nsCOMPtr<nsIEventTarget>::~nsCOMPtr [nsCOMPtr.h : 487 + 0x8]
    eip = 0x011f769c   esp = 0xbf9ae880   ebp = 0xbf9ae898   ebx = 0x02cc31e8
    esi = 0x09e6670c   edi = 0x00000000
    Found by: call frame info
 6  libxul.so!nsAsyncStreamCopier::~nsAsyncStreamCopier [nsAsyncStreamCopier.cpp : 39 + 0xa]
    eip = 0x011f8420   esp = 0xbf9ae8a0   ebp = 0xbf9ae8b8   ebx = 0x02cc31e8
    esi = 0x09e666f0   edi = 0x00000000
    Found by: call frame info
 7  libxul.so!nsAsyncStreamCopier::~nsAsyncStreamCopier [nsAsyncStreamCopier.cpp : 42 + 0x8]
    eip = 0x011f846e   esp = 0xbf9ae8c0   ebp = 0xbf9ae8d8   ebx = 0x02cc31e8
    esi = 0x09e666f0   edi = 0x00000000
    Found by: call frame info
 8  libxul.so!nsAsyncStreamCopier::Release [nsAsyncStreamCopier.cpp : 93 + 0x3]
    eip = 0x011f80fb   esp = 0xbf9ae8e0   ebp = 0xbf9ae908   ebx = 0x02cc31e8
    esi = 0x09e666f0   edi = 0x00000000
    Found by: call frame info
 9  libxul.so!XPCJSRuntime::GCCallback [XPCJSRuntime.cpp : 588 + 0xa]
    eip = 0x01be077a   esp = 0xbf9ae910   ebp = 0xbf9ae958   ebx = 0x02cc31e8
    esi = 0x097e7320   edi = 0x097e74a4
    Found by: call frame info
10  libxul.so!Collect [jsgc.cpp : 3793 + 0xc]
    eip = 0x02488c31   esp = 0xbf9ae960   ebp = 0xbf9ae9d8   ebx = 0x02cc31e8
    esi = 0x0980b4b0   edi = 0x0980b6bc
    Found by: call frame info
}
Comment 5 Treeherder Robot 2012-06-10 17:45:50 PDT
dbaron
https://tbpl.mozilla.org/php/getParsedLog.php?id=12536176&tree=Mozilla-Aurora
Rev3 Fedora 12 mozilla-aurora debug test xpcshell on 2012-06-10 15:48:38
slave: talos-r3-fed-041

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 6 Treeherder Robot 2012-06-21 08:02:01 PDT
billm
https://tbpl.mozilla.org/php/getParsedLog.php?id=12848166&tree=Try
Rev3 Fedora 12 try debug test xpcshell on 2012-06-20 19:02:58
slave: talos-r3-fed-043

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 7 Treeherder Robot 2012-06-27 17:42:45 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=13054160&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-06-27 16:51:39
slave: talos-r3-fed-066

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 8 Treeherder Robot 2012-06-28 18:27:32 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=13087864&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-06-28 17:37:35
slave: talos-r3-fed-029

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 9 Treeherder Robot 2012-06-29 14:27:34 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=13098758&tree=Ionmonkey
Rev3 Fedora 12 ionmonkey debug test xpcshell on 2012-06-29 02:45:17
slave: talos-r3-fed-025

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 10 Treeherder Robot 2012-06-30 06:01:50 PDT
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=13125680&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-06-29 23:23:22
slave: talos-r3-fed-005

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 11 Treeherder Robot 2012-07-01 19:46:01 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=13153938&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-07-01 18:36:22
slave: talos-r3-fed-005

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 12 Treeherder Robot 2012-07-03 04:40:06 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=13188598&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-07-03 03:44:56
slave: talos-r3-fed-027

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 13 Treeherder Robot 2012-07-10 05:34:51 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=13386972&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-07-10 04:37:16
slave: talos-r3-fed-007

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 14 Treeherder Robot 2012-07-10 14:43:28 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=13401918&tree=Firefox
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2012-07-10 13:45:23
slave: talos-r3-fed-031

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 15 Treeherder Robot 2012-07-11 03:38:12 PDT
bill%wg9s.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=13420560&tree=Firefox
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2012-07-11 02:35:37
slave: talos-r3-fed-041

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 16 :Benjamin Peterson 2012-07-11 22:06:12 PDT
I considered test_history_tracker.js. The problem is the timer in Tracker.saveChangedIDs is being called during XPCOM thread shutdown. It starts invoking the networking subsystem through NetUtil.asyncCopy, which spawns a thread pool. This thread pool later asserts because it expected to be cleaned up earlier in XPCOM shutdown. I suppose that timer should be cleared when the test is done?
Comment 17 Treeherder Robot 2012-07-11 23:09:14 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=13444732&tree=Fx-Team
Rev3 Fedora 12 fx-team debug test xpcshell on 2012-07-11 18:31:50
slave: talos-r3-fed-053

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 18 Treeherder Robot 2012-07-11 23:26:46 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=13446186&tree=Ionmonkey
Rev3 Fedora 12 ionmonkey debug test xpcshell on 2012-07-11 19:43:27
slave: talos-r3-fed-014

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 19 :Benjamin Peterson 2012-07-12 14:14:37 PDT
Created attachment 641592 [details] [diff] [review]
clear io timer
Comment 20 Philipp von Weitershausen [:philikon] 2012-07-12 14:20:01 PDT
Comment on attachment 641592 [details] [diff] [review]
clear io timer

Going in the right direction. Two points:

* We should probably do this to all tracker tests.

* Just to be safe, guard the clear() call against the timer already having fired:

  if (tracker._lazySave) {
    tracker._lazySave.clear();
  }
Comment 21 :Benjamin Peterson 2012-07-12 15:11:08 PDT
Created attachment 641622 [details] [diff] [review]
clear io timer
Comment 22 Philipp von Weitershausen [:philikon] 2012-07-12 15:15:00 PDT
Comment on attachment 641622 [details] [diff] [review]
clear io timer

Review of attachment 641622 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the points below addressed.

::: services/sync/tests/unit/test_bookmark_store.js
@@ +301,5 @@
>    } finally {
>      Svc.Obs.notify("weave:engine:stop-tracking");
>      _("Clean up.");
> +    if (engine._tracker._lazyStore) {
> +      engine._tracker._lazyStore.clear();

lazyStore? I thought it was lazySave...

::: services/sync/tests/unit/test_tab_tracker.js
@@ +107,5 @@
>    tracker.onTab({type: "pageshow", originalTarget: "pageshow"});
>    do_check_true(Utils.deepEquals(Object.keys(engine.getChangedIDs()),
>                                   [Clients.localID]));
>    do_check_eq(logs.length, idx); // test that setTabValue isn't called
> +  if ("_lazySave" in tracker) {

`if (tracker._lazySave)` is safer because `tracker._lazySave` could be `null`.
Comment 23 :Benjamin Peterson 2012-07-12 15:29:55 PDT
Created attachment 641629 [details] [diff] [review]
clear io timer
Comment 24 Ryan VanderMeulen [:RyanVM] 2012-07-12 16:37:23 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/01dee496d82f
Comment 25 Gregory Szorc [:gps] 2012-07-12 16:40:29 PDT
https://hg.mozilla.org/services/services-central/rev/f20846d5c1f1

Boo for race conditions.

Thanks for the patch!
Comment 26 Treeherder Robot 2012-07-12 17:31:03 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=13472488&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-07-12 16:26:40
slave: talos-r3-fed-005

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 27 Ed Morley [:emorley] 2012-07-13 05:30:56 PDT
https://hg.mozilla.org/mozilla-central/rev/01dee496d82f
Comment 28 Gregory Szorc [:gps] 2012-07-14 13:39:30 PDT
https://hg.mozilla.org/mozilla-central/rev/f20846d5c1f1

Double land!
Comment 29 Ed Morley [:emorley] 2012-07-18 07:16:43 PDT
*** Bug 775086 has been marked as a duplicate of this bug. ***
Comment 30 Treeherder Robot 2012-08-01 04:58:37 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=14032718&tree=Mozilla-Beta
Rev3 Fedora 12 mozilla-beta debug test xpcshell on 2012-08-01 02:55:49
slave: talos-r3-fed-023

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 31 Ed Morley [:emorley] 2012-08-02 04:54:54 PDT
Comment on attachment 641629 [details] [diff] [review]
clear io timer

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Unknown
User impact if declined: intermittent [orange]
Testing completed (on m-c, etc.): Fixed on Fx16 and higher
Risk to taking this patch (and alternatives if risky): Test-only change
String or UUID changes made by this patch: None
Comment 32 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-03 11:17:00 PDT
Comment on attachment 641629 [details] [diff] [review]
clear io timer

[Triage comment]
test-only change, approving.
Comment 34 Ed Morley [:emorley] 2012-08-14 08:19:58 PDT
Ioana: if it helps, anything with [orange] in the whiteboard will not need verifying by QA, since it was filed as a result of failures from TBPL. If the failures were not fixed then sheriffs will have already reopened the bug when starring it. As such, it might be worth suggesting to the QA team that your saved searches are modified to exclude sw:[orange]
Comment 35 Ioana (away) 2012-08-14 08:23:03 PDT
(In reply to Ed Morley [:edmorley] from comment #34)
> Ioana: if it helps, anything with [orange] in the whiteboard will not need
> verifying by QA, since it was filed as a result of failures from TBPL. If
> the failures were not fixed then sheriffs will have already reopened the bug
> when starring it. As such, it might be worth suggesting to the QA team that
> your saved searches are modified to exclude sw:[orange]

Thanks Ed! I'll make sure we exclude it from our searches.
Comment 36 Ed Morley [:emorley] 2012-08-14 08:29:00 PDT
(In reply to Ioana Budnar [QA] from comment #35)
> Thanks Ed! I'll make sure we exclude it from our searches.

Awesome - thank you :-D
Comment 37 Treeherder Robot 2012-10-24 22:40:38 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=16444987&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test xpcshell on 2012-10-24 21:43:54
slave: talos-r3-fed-053

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: -11), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 38 Treeherder Robot 2012-10-26 14:56:53 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=16502736&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound debug test xpcshell on 2012-10-26 14:03:36
slave: talos-r3-fed64-020

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | test failed (with xpcshell return code: -11), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_bookmark_store.js | application crashed (minidump found)
Thread 0 (crashed)
Comment 39 Treeherder Robot 2013-01-08 23:17:41 PST
jimb
https://tbpl.mozilla.org/php/getParsedLog.php?id=18578765&tree=Try
Rev3 WINNT 6.1 try debug test xpcshell on 2013-01-07 20:10:54
slave: talos-r3-w7-093

TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\services\sync\tests\unit\test_history_tracker.js | test failed (with xpcshell return code: -2147483645), see following log:
PROCESS-CRASH | C:\talos-slave\test\build\xpcshell\tests\services\sync\tests\unit\test_history_tracker.js | application crashed [@ mozalloc_abort(char const * const)]
Thread 0 (crashed)

Note You need to log in before you can comment on or make changes to this bug.