SpecialFolder icon problems with folderPane.css

VERIFIED FIXED in mozilla0.9.2

Status

P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: sspitzer, Assigned: hwaara)

Tracking

({classic, modern})

Trunk
mozilla0.9.2
x86
All
classic, modern

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

andrew, I noticed a bunch of problems with folderPane.css in the classic skin.

examples:  there are no rules in folderPane.css for templates folder and the sent.

looking at hewitt's folderPane.css (for modern) perhaps we can follow that.

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Keywords: nsbeta1

Comment 1

18 years ago
Themes Triage Team Marking nsbeta1+
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla0.9.1
(Assignee)

Updated

18 years ago
Keywords: classic

Comment 2

18 years ago
Created attachment 32072 [details] [diff] [review]
changes to mac folderpane.css

Comment 3

18 years ago
got mac, now windows.

Comment 4

18 years ago
Created attachment 33965 [details] [diff] [review]
folderpane.css changes to windows classic

Comment 5

18 years ago
sr=hewitt

Comment 6

18 years ago
r=lordpixel

I see new drafts, sent and templates icons after applying this

Comment 7

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
Using build 2001-05-25 on win, mac and linux I see Special Folder icons for 
Drafts, Templates, Sent and Trash in Classic.  They are different icons than 
Modern, is there a link to the spec where I can see the icons so I can confirm 
they are the right icons?
The only spec I saw on http://www.mozilla.org/mailnews/specs was for Modern, but
Jennifer might be able to just view Classic and verify that they look alright.

Comment 10

18 years ago
So 72816 would be a dup of this bug?

Comparing classic skin to 4.x, Inbox, Drafts, Templates, Sent and Trash appear 
to be using the correct icons. "Unsent Messages" is still using a generic folder 
though instead of the 4.x icon.
(Assignee)

Comment 11

18 years ago
Jglick, yes, that bug is a duplicate of this.

I (virtually) have a fix in hand. Will attach it soon.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Assignee)

Comment 12

18 years ago
Taking
Assignee: andreww → hwaara
Status: REOPENED → NEW
(Assignee)

Comment 13

18 years ago
keep andreww as cc

Comment 14

18 years ago
thanks :)

Make sure you love mac classic as much as windows classic.
(Assignee)

Comment 15

18 years ago
Rebuilding and testing a possible fix for this right now...
Status: NEW → ASSIGNED
(Assignee)

Comment 16

18 years ago
*** Bug 72816 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

18 years ago
Created attachment 36641 [details] [diff] [review]
fix
(Assignee)

Comment 18

18 years ago
Fixed and tested on all themes. The problem was that the CSS for it simply
wasn't written.

andreww, hewitt - wanna review this?

Comment 19

18 years ago
on build 2001-05-30 (modern theme) there are stil several special folders that
still use the default folder icon:
- IMAP "Sent Items" 
- POP "nstmp" 
- Local Folders "unsent messages" 

Will this be fixed for BOTH themes by you patch? If not this bug shouldn't be
closed, or we need a new bug.

Comment 20

18 years ago
The above is true for the classic theme as well:
On build 2001-05-30 (CLASSIC theme) there are stil several special folders that
still use the default folder icon:
- IMAP "Sent Items" 
- POP "nstmp" (name@csi.com -> comuserve)
- Local Folders "unsent messages" 

BTW, I filed bug 83459 for this in the modern theme.
(Assignee)

Comment 21

18 years ago
yes, both skins.
Keywords: modern
Summary: SpecialFolder icon problems with folderPane.css in classic skin → SpecialFolder icon problems with folderPane.css

Comment 22

18 years ago
r = andreww for hwaara's patch.

Comment 23

18 years ago
sr=hewitt
a=dbaron for trunk checkin
(Assignee)

Comment 25

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 26

18 years ago
Verified fixed in the win nightly from today.

Comment 27

17 years ago
We no longer have a Sent Items folder (I only saw it with AOL accounts originally)
It's now called Sent Mail and is not a special folder.
POP "nstmp" is a bug, this should not have been created, so it's not a special
folder
All other special foldder icons are displaying on Win, mac and linux in both
Classic and Modern
Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.