If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Video width scalling doesn't work properly under certain value

RESOLVED INVALID

Status

()

Core
Audio/Video
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

11 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 593337 [details]
screenshot

Platforms: all

Mozilla/5.0 (Windows NT 6.1; rv:11.0a2) Gecko/20120129 Firefox/11.0a2

When scalling videos width smaller window, video doesn't scale under some value (328px), unless height is also reduced.

Steps to reproduce:
1. Go to http://download.blender.org/peach/trailer/trailer_1080p.ogg
2. Reduce the window width to under 300 px (by dragging only horizontaly)

Expected result:
Video should resize to match the window size at any dimension

Actual result:
Video doesn't scale to fit the window when width is minimized under 328 px unless window height is also reduced (to less than video height). Still, the video does not center anymore.

Note: reproducible also in Nighly(12.0a1), but at width under 250 px.
Mozilla/5.0 (Windows NT 6.1; rv:12.0a1) Gecko/20120131 Firefox/12.0a1
This is because the browser doesn't shrink the size of tabbed browser below a value near 328 pixels.

You can see this when resizing the browser how the navigation toolbar will flex the size of the address bar to a certain point and then any smaller and the navigation toolbar items are clipped.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Yep.  If you need to test resizing behavior, use an iframe whose size you set.

And please do file a Firefox front-end bug on the not-shrinking-below-328px behavior.
Resolution: WONTFIX → INVALID
You need to log in before you can comment on or make changes to this bug.