Table cell borders cannot be changed dynamically

RESOLVED FIXED in mozilla0.9

Status

()

RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: erik, Assigned: kmcclusk)

Tracking

Trunk
mozilla0.9
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The style for borders of table cells (only td tested) cannot be changed 
dynamically.

Neither setting the style.border* or changing the className (to change the 
border) updates the visual state of the border for table cells.

This works fine for block and inline elements.

Even if this is just a visual bug I think it is a rather serious bug because it 
is a commonly used task.
(Reporter)

Comment 1

18 years ago
Created attachment 27976 [details]
Press mouse button on any of the cells and notice that the border does not change
Table reflow/painting problem, over to karnaze.
Assignee: jst → karnaze

Comment 3

18 years ago
The testcase works on the 1st cell of each row but not the 2nd cell. I changed 
the testcase to have only one row and in the 2nd cell to not do the onmouseup. 
Mousing on the 2nd cell still did not show the correct border until I minimized 
and maximized Viewer. Since, the table cell frame is invalidating its entire 
rect during this kind of reflow, I am suspecting a rendering problem. 
Reassigning to kmcclusk.
Assignee: karnaze → kmcclusk
Target Milestone: --- → mozilla0.9.1

Comment 4

18 years ago
*** Bug 70756 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
From bug 70756 (in case this really isn't a dup) - "Even though nsTableCellFrame 
is invalidating its entire rect, when it gets painted, the dirty rect is not 
right."
QA Contact: ian → amar
(Assignee)

Comment 6

18 years ago
Most of the borders change color when I hold down over them. Portions of some of
the borders do not change color. This is most likely a twips->pixel roundoff
error when invalidating the bounds for the frame. All frames (x,y) offset must
be aligned to pixel boundaries.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
It is working correctly in todays build. My change to text frame invalidation
may have fixed the problem. Marking bug FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9
You need to log in before you can comment on or make changes to this bug.