Pressing ESC key while webm video loads doesn't stop video loading

RESOLVED DUPLICATE of bug 559468

Status

()

Toolkit
Video/Audio Controls
RESOLVED DUPLICATE of bug 559468
6 years ago
2 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

11 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Platforms: Win XP, Ubuntu 11.04 32 bit, Mac 10.6

Steps:
1. Go to http://videos-cdn.mozilla.net/brand/Mozilla_Firefox_Manifesto_v0.2_640.webm (or http://videos-cdn.mozilla.net/serv/webmademovies/Moz_Doc_0329_GetInvolved_ST.webm)
2. While video is loading (immediately after page load) hit the ESC key

Actual result:
Video loads and starts playing

Expected result:
Video stops loading and error message "Video loading stopped." is displayed overlaying the video

Note: On Win 7 32 bit, Win 7 64 bit and Ubuntu 11.04 64bit the behaviour is the expected one.
The only way I can reproduce this (on Win7 x64) is when the video is fully stored in the network cache, and so the video loads instantly. So pressing ESC isn't stopping autoplay in that case because the resource can autoplay since its fully loaded.

I don't actually think we want to force playback to stop in this case: pressing ESC is supposed to stop network activity, not video playback.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559468
You need to log in before you can comment on or make changes to this bug.