Status

()

Toolkit
Application Update
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: vijay, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:13.0a1) Gecko/20120201 Firefox/13.0a1
Build ID: 20120201031146

Steps to reproduce:

I've installed the latest mozilla nightly12...


Actual results:

It shows that a new update is available (12.0a version). Everything goes on normally after that. But it shows that the same update is available again and downloads it again, every time I restart the system.


Expected results:

The update should have taken place, but it always repeats the update again and again.
(Reporter)

Updated

7 years ago
Severity: normal → major
Hardware: x86 → x86_64

Updated

7 years ago
Component: Untriaged → Application Update
Product: Firefox → Toolkit
QA Contact: untriaged → application.update
Version: 13 Branch → Trunk
Please attach (using the 'Add an attachment' link above) the following files which can be located with a default install as follows (uses paths for the default install location so if you changed it they need to be adjusted:

for Windows Vista and above type the following in the Start Menu search box and press return.
%LOCALAPPDATA%
Then navigate to \Mozilla\Firefox\Nightly\

for Windows prior to Windows Vista type the following in the Start Menu -> run box and press return.
%USERPROFILE%
Then navigate to \Local Settings\Application Data\Mozilla\Firefox\Nightly\

active-update.xml
updates.xml

navigate to the updates subdirectory
last-update.log and backup-update.log

Also, do you have a 32 bit build installed as well?
(Reporter)

Comment 2

7 years ago
Created attachment 593750 [details]
updates.xml
(Reporter)

Comment 3

7 years ago
Created attachment 593751 [details]
active-update.xml
(Reporter)

Comment 4

7 years ago
Created attachment 593753 [details]
backup-update.log
(Reporter)

Comment 5

7 years ago
Created attachment 593754 [details]
last-update.log
(Reporter)

Comment 6

7 years ago
i'm using 64-bit version.
I looked into last-update.log and backup-update.log and they just show success.  active-update.xml is empty as it should be.  updates.xml lists the v13 upgrade as if it was applied.

I have to query for more info...

> But it shows that the same update is available again and downloads 
> it again, every time I restart the system.

By restart the system do you mean just a browser restart or a whole computer reboot? If you mean computer reboot can you confirm if the problem happens on browser restart as well?

--

Could you try opening your browser, going to the about menu and before pressing apply update, go to this path again:
%LOCALAPPDATA%
Then navigate to \Mozilla\Firefox\Nightly\

Then please attach a zip with all of the same files as before as well as update.status and update.version.

After that please press apply update in the about dialog.  Then when it restarts after applying the update, please check the about dialog again.  Does it re-download the update and give an apply button again immediately?  If so, and if you don't mind, a second zip with the same files again would be great so I could compare before and after.
(Reporter)

Comment 8

7 years ago
The problem was solved when the latest update was applied.
The latest Nightly 13.0a version does not show the above problem.
Thanks anyway.
Maybe something related to 12->13.  I tried this though and it worked so I will mark this as invalid for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.