Last Comment Bug 723159 - Base64.decode not available on eclair
: Base64.decode not available on eclair
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Firefox 13
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
Depends on: 662891 723870 723955
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 09:34 PST by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-03-08 09:06 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified


Attachments
patch (10.47 KB, patch)
2012-02-01 11:38 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Brad Lassey [:blassey] (use needinfo?) 2012-02-01 09:34:32 PST
We use this for tab screenshots and something else I that I can't remember right now.

W/System.err(  445): java.lang.NoClassDefFoundError: android.util.Base64
W/System.err(  445): 	at org.mozilla.gecko.Tabs.handleMessage(Tabs.java:282)
W/System.err(  445): 	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:1645)
W/System.err(  445): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err(  445): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2012-02-01 11:38:29 PST
Created attachment 593543 [details] [diff] [review]
patch
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-02-01 12:38:18 PST
Comment on attachment 593543 [details] [diff] [review]
patch

There's a base64 implementation in mobile/android/base/apache/commons/codec/binary/ - can we not reuse that one?
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-02-01 15:59:36 PST
(In reply to Kartikaya Gupta (:kats) from comment #2)
> Comment on attachment 593543 [details] [diff] [review]
> patch
> 
> There's a base64 implementation in
> mobile/android/base/apache/commons/codec/binary/ - can we not reuse that one?

that is from sync, and will hopefully be going away soon. Fennec code should not depend on it.
Comment 4 Ed Morley [:emorley] 2012-02-02 07:16:25 PST
https://hg.mozilla.org/mozilla-central/rev/9022268bea45
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-02-02 14:15:39 PST
Comment on attachment 593543 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined:
crash on eclair 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Comment 6 Alex Keybl [:akeybl] 2012-02-05 13:45:16 PST
Comment on attachment 593543 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 13:49:47 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/09b1dc4ff4a9
Comment 8 Cristian Nicolae (:xti) 2012-03-07 02:38:24 PST
Verified fixed on:

Firefox 13.0a1 (2012-03-06)
20120306031101
http://hg.mozilla.org/mozilla-central/rev/7d0d1108a14e

--
Device: HTC Desire
OS: Android 2.2
Comment 9 Kevin Brosnan [:kbrosnan] 2012-03-07 10:47:58 PST
This bug needs a 2.1 (Eclair) phone to be verified. This is currently broken by other work. To verify you would need to use a build near the checkin date of 2012-02-02.
Comment 10 Cristian Nicolae (:xti) 2012-03-08 09:06:21 PST
(In reply to Kevin Brosnan [:kbrosnan] from comment #9)
> This bug needs a 2.1 (Eclair) phone to be verified. This is currently broken
> by other work. To verify you would need to use a build near the checkin date
> of 2012-02-02.

Right, I will check it again on a 2.1 device. My mistake, sorry.

Note You need to log in before you can comment on or make changes to this bug.