polish new mail outliner threadpane

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
Themes
P1
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Joe Hewitt (gone), Assigned: Joe Hewitt (gone))

Tracking

Trunk
mozilla0.9
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
The new threadpane is AAAAAAAAAAAAAWESOME!!!!!!!!!!!  I'm overwhelmed with glee
tonight.  Now all is needed is to do a little polish work on the themes.  The
follow issues stand out:

1. the edges where the outliner meets the splitter need borders
2. the focus ring doesn't appear on the thread pane
3. clicking headers with images causes jumpiness
4. selected row border/background colors aren't quite right

I've fixed this stuff already, will post patch shortly.

Comment 1

18 years ago
thanks for looking into this Joe.

I had a focus ring working before I merged with the new modern changes but I
broke it during that process and couldn't figure out what i did =).

If you have time, currently mac classic == win classic for outliner.css. Maybe
we can get someone on mozilla to do this for us too.
(Assignee)

Comment 2

18 years ago
*** Bug 72894 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

18 years ago
Created attachment 28441 [details] [diff] [review]
patch to fix
(Assignee)

Comment 4

18 years ago
I should note that this fix also goes the extra mile to make the focus rings Mac
Classic Mail not look like crap.
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9

Comment 5

18 years ago
hewitt is such a sexy bitch. hyatt, you owe him some closet time for this one. 
r=blake

Comment 6

18 years ago
sr=hyatt

Updated

18 years ago
Blocks: 73112

Updated

18 years ago
Blocks: 73113
(Assignee)

Comment 7

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
marking verified on all platforms (2001-04-25-09-Mtrunk)
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.