Possible compiler bug with MSVC 2010 causes miscompilation of CSSParserImpl::ParseProperty

RESOLVED FIXED in Firefox 40

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: khuey, Assigned: m_kato)

Tracking

Trunk
mozilla40
Points:
---

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Blocks: 563318
https://connect.microsoft.com/VisualStudio/feedback/details/722282/msvc-2010-appears-to-miscompile-cssparserimpl-parseproperty-during-the-profiling-run-of-a-pgo-build
Ftr, a |#pragma optimize( "", off )| was added as a workaround in bug 563318 comment 39:
https://hg.mozilla.org/mozilla-central/rev/a54f31fa1efd
Version: unspecified → Trunk
(Assignee)

Comment 3

2 years ago
no PGO error on our VS2013 builder
https://treeherder.mozilla.org/#/jobs?repo=try&revision=47b6686624b3
(Assignee)

Comment 4

2 years ago
try again. no PGO error of original.  (although hitting bug1115490 after building successful)
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a5e91d698177
(Assignee)

Comment 5

2 years ago
Created attachment 8588523 [details] [diff] [review]
Remove old workaround of VS2010
(Assignee)

Comment 6

2 years ago
Comment on attachment 8588523 [details] [diff] [review]
Remove old workaround of VS2010

When using VS2010, it throws ICE (internal compiler error) when building source file.

But using VS2013, no error when building and linking.
Attachment #8588523 - Flags: review?(mshal)
Comment on attachment 8588523 [details] [diff] [review]
Remove old workaround of VS2010

Although the change looks fine to me, I think you'll need someone in this module for review.

Also the "command timed out" error may or may not be related. That just means that something in the build is hanging - it's possible this patch is introducing a new thing that times out, though that is probably unlikely.
Attachment #8588523 - Flags: review?(mshal)
(Assignee)

Comment 8

2 years ago
Comment on attachment 8588523 [details] [diff] [review]
Remove old workaround of VS2010

try server is successful during PGO building on VS2013.

When using VS2010, ICE (internal compile error on building) occurred.
Attachment #8588523 - Flags: review?(dbaron)
Attachment #8588523 - Flags: review?(dbaron) → review+
(Assignee)

Comment 9

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/38291788a6f4
(Assignee)

Updated

2 years ago
Assignee: nobody → m_kato
https://hg.mozilla.org/mozilla-central/rev/38291788a6f4
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
(Assignee)

Updated

2 years ago
Duplicate of this bug: 744354
You need to log in before you can comment on or make changes to this bug.