form object "submit" when using "size > 1" does not display correctly (recently appeared in mozilla)

VERIFIED DUPLICATE of bug 71183

Status

()

--
major
VERIFIED DUPLICATE of bug 71183
18 years ago
18 years ago

People

(Reporter: crazney, Assigned: karnaze)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0 i686; en-US; 0.8.1) Gecko/20010316
BuildID:    20010316

in an html page, when there is a form like:

<select name="rating" size="3">
<option value="1">1</option>
<option value="2">2</option>
</select>

it doesnt show up at all (mozilla seems to put the space there, but there is
nothing there!).
BUT, the page shows fine in konqueror / netscape / IE.

(Screenshots:
http://crazney.net/mozform.jpg <--- shows form in mozilla.
http://crazney.net/konqform.jpg <--- shows form in konqueror.
)


Reproducible: Always
Steps to Reproduce:
1. Goto the URL http://dev.mindmyseat.com/search.php?country=1&city=1&category=1
(please keep this URL private!)
2. And look.


Actual Results:  There is no form object.

Expected Results:  There should be a form object.

Comment 1

18 years ago
Not form manager.  Reassigning.
Assignee: morse → karnaze
Component: Form Manager → Layout
QA Contact: tpreston → petersen

Comment 2

18 years ago
I can confirm that this fails on win32 as well.  Changing OS to all and changing 
from unconfirmed to new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
There are <font> tags about those <select>s.  Removing the <font> tags fixes
things.  Marking duplicate of "<select> not rendered when enclosed in another
tag (<small>, <font>, <tt>)"

*** This bug has been marked as a duplicate of 71183 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
vrfy
You need to log in before you can comment on or make changes to this bug.