Last Comment Bug 723243 - SimpleScaleGestureDetector uses getActionIndex(), which is not available in eclair
: SimpleScaleGestureDetector uses getActionIndex(), which is not available in e...
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Firefox 13
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 12:10 PST by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-02-06 19:30 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed


Attachments
patch (1.57 KB, patch)
2012-02-01 12:10 PST, Brad Lassey [:blassey] (use needinfo?)
wjohnston2000: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2012-02-01 12:10:34 PST
Created attachment 593554 [details] [diff] [review]
patch

This is just a convenience function which was introduced in Froyo. It is the equivalent of: 

(event.getAction() & MotionEvent.ACTION_POINTER_ID_MASK) >> MotionEvent.ACTION_POINTER_ID_SHIFT

but, ACTION_POINTER_ID_* was renamed to ACTION_POINTER_INDEX_* in Froyo, so I used those constants in the patch
Comment 1 Ed Morley [:emorley] 2012-02-02 07:16:30 PST
https://hg.mozilla.org/mozilla-central/rev/6befd1389592
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2012-02-02 14:18:05 PST
Comment on attachment 593554 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Crash when touching on eclair
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Comment 3 Alex Keybl [:akeybl] 2012-02-05 13:45:51 PST
Comment on attachment 593554 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2012-02-06 09:21:30 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/49f5c924b7a5
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 18:43:29 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/02d946fad4c7
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 19:29:37 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/1e79aa665449
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 19:30:34 PST
(In reply to Brad Lassey [:blassey] from comment #5)
> https://hg.mozilla.org/releases/mozilla-beta/rev/02d946fad4c7

this is actually bug 723151's patch

Note You need to log in before you can comment on or make changes to this bug.