firefox-10.0esr -safe-mode makes me select add-ons

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: jja, Unassigned)

Tracking

10 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

150.61 KB, image/png
Details
(Reporter)

Description

7 years ago
Created attachment 593557 [details]
Screenshot

User Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.25) Gecko/20111212 Firefox/3.6.25
Build ID: 20111212142243

Steps to reproduce:

./firefox -safe-mode


Actual results:

firefox dialog tells me to "Select Your Add-ons"


Expected results:

firefox should disable all Add-ons and start without user intervention
(Reporter)

Updated

7 years ago
Hardware: x86 → x86_64
Did you upgrade to ESR from a 3.6 Firefox?
Did you use the ESR previously-were all your add-ons enabled and working before starting in safe mode?
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: untriaged → add-ons.manager
(Reporter)

Comment 2

7 years ago
Yes, I am currently running 3.6 with everything working. Some add-ons are enabled, some disabled. This was the first time running ESR and I did so from a fresh install dir and in safe-mode hoping to avoid add-on upgrade/version issues, but I did not move ~/.mozilla out of the way (hence the LoadPlugin errors you see in my terminal).
This seems to be working as expected. That dialog is meant to show the first time you run Firefox 10 with a profile from any previous version of Firefox.
Indeed, this is expected as specified in bug 596343. Any update from 3.6.* to Firefox 10.* would show the Select Add-on UI when running the upgraded Firefox for the first time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.