[RFE]remap hotkey to cycle/switch windows for some keyboard layouts (User-definable key bindings)

VERIFIED DUPLICATE of bug 53505

Status

()

Core
Keyboard: Navigation
--
enhancement
VERIFIED DUPLICATE of bug 53505
17 years ago
16 years ago

People

(Reporter: Giovanni Gatti, Assigned: Alec Flett)

Tracking

Trunk
mozilla1.0
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
just like IE, I'd like to have an hotkey (suitable for portable computers with
their limited keyboard, and for foreign languages layouts) that switches through
open windows.

Comment 1

17 years ago
Why Command+1 and +2 do not do your job?
(Reporter)

Comment 2

17 years ago
I use a powerbook with Italian keyboard, so I don't have the numeric pad, and
the command 1 key does not work

Comment 3

17 years ago
I see. The same problem applies to Belgium and French keyboards at least.
Since command+shift+1 is reserved by MacOS, command+1 is not possible in those
keyboard layouts, I suppose. An obvious workaround is switching keyboard layout
to other by command+option+space, but that would force a user to switch layout,
use command+1, and then switch back the key layout.
There is an outstanding bug 53505 that likely solves this specific problem.
Adding dependency and modified the summary.(I typed this using Italian layout!)
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Browser-General → Keyboard Navigation
Depends on: 53505
Ever confirmed: true
Summary: hotkey to switch windows → [RFE]remap hotkey to switch windows for some keyboard layouts (User-definable key bindings)
Target Milestone: --- → mozilla1.0

Comment 4

17 years ago
i detect a miscommunication ...

i am surprised that cmd-1 does not work for giovanni.  it is not necessary that
the 1 be a keypad-1.  cmd-1 should work fine using the regular 1 on the
keyboard.  if it doesn't, perhaps this is a bug that cmd-1 doesn't work for an
italian keyboard layout.

i understand that cmd-1 will cycle open navigator windows one direction, since
cmd-shift-1 is indeed reserved.  but cmd-1 & cmd-2 should be available as viable
workarounds as key-shortcuts until bug 53505 is resolved/implemented.


Comment 5

17 years ago
There is no miscommunication here. I tested myself using Italian kayboard layout
as well as French and Belgian. MacOS can switch keyboard layout quite easily.
If you set the keyboard layout to Italian, number 1-0 are mapped to uppercase
instead of lowercase. Thus, there is no way of making command+1 without pressing
the shift key.

Comment 6

17 years ago
we have other bugs requesting more keymap flexibility. this should happen by 
1.0 please pick a bug and dupe this against it.
Keywords: qawanted
Whiteboard: DUPEME

Comment 7

17 years ago
I think this is a duplicate of 53505, unless timeless, did you want it duped 
against some bug about giving the user a user interface to remap keys for 
themselves? 

While that's a good goal, I think this is about having a sensible default. 
Matthew's design in 53505 (ctrl for frame, option for window and command for app) 
looks good to me.

Comment 8

17 years ago
reassign
Assignee: asa → alecf
QA Contact: doronr → sairuh
(Assignee)

Updated

17 years ago
Summary: [RFE]remap hotkey to switch windows for some keyboard layouts (User-definable key bindings) → [RFE]remap hotkey to cycle/switch windows for some keyboard layouts (User-definable key bindings)
i agree with lordpixel and timeless --this really sounds like a dup of bug 53505.

*** This bug has been marked as a duplicate of 53505 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
No longer depends on: 53505
Keywords: qawanted
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.