Firefox hang after video call finished

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: t.osiara+mozilla, Unassigned)

Tracking

10 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

I finished video call using Google Video Chat plugin by pressing "End" button.


Actual results:

The video call ends and Firefox is not responding for 10-15 seconds


Expected results:

Firefox should not hang after video call. Chrome browser works fine with the same plugin version.

Reproducible: always
openSuse 11.4 32bit, latest Firefox 10, latest Google Video Chat plugin
(Reporter)

Updated

7 years ago
Severity: normal → major
OS: Windows 7 → Linux
Hardware: x86_64 → x86
(Reporter)

Comment 1

7 years ago
This only happens on Linux. Tested Mac OS X and Windows - no problems found. Tested Chrome browser - no problems found
Can you reproduce this with a clean profile in F10?
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Component: Untriaged → Plug-ins
Product: Firefox → Core
QA Contact: untriaged → plugins
(Reporter)

Comment 3

7 years ago
Hi,

yes, the issue is reproducible with a brand new profile (I have even created a new system user specially for the test)
Mozilla/5.0 (X11; Linux x86_64; rv:13.0a1) Gecko/20120213 Firefox/13.0a1

Works for me with version 2.6.1.0 of Google talk plugin when testing on gmail.com using video chat. No hangs after finishing the call. I am using Ubuntu 11.10.

tosiara, did this work for you in previous Firefox versions? Could you try the latest Nightly and see if you can reproduce?  http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 5

7 years ago
1. This worked fine until F9. I can't remember exactly when it happened first, but now both workstation and laptop has this issue.

2. Tested Nightly build - I cannot reproduce using version 13.0a1 (2012-02-14)

3. Also, what I noticed, if launched from a command line, when the issue occurs in F10 there are a lot of such messages:

[0214/195513:ERROR:message_queue.cc(391)] nacl::ReceiveMessage failed : Connection reset by peer
[0214/195526:ERROR:message_queue.cc(391)] nacl::ReceiveMessage failed : Connection reset by peer
[0214/195536:ERROR:message_queue.cc(391)] nacl::ReceiveMessage failed : Connection reset by peer
[0214/195536:ERROR:message_queue.cc(391)] nacl::ReceiveMessage failed : Connection reset by peer
*** NSPlugin Wrapper *** ERROR: NPClass::Deallocate() wait for reply: Message timeout
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0xb46d29c0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0xb46cd900 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0xb46cd6c0 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0xb46d3a90 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0xb46cd240 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0xb46d5e70 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0xb46d20c0 is no longer valid!
...
..

and so on (about 100 lines)


Hope this helps
Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

Works for me for Firefox 10 too. 

is this a build that comes with your distribution of openSuse? or is this a Firefox build(e.g. mozilla.org)?
(Reporter)

Comment 7

7 years ago
It is branded version, that comes with openSUSE (available in online repo: http://download.opensuse.org/update/11.4/rpm/src/MozillaFirefox-10.0.2-0.2.1.src.rpm)

I have just tried downloading 10.0.2 version from mozilla and it works fine! Also I noticed there is no "NSPlugin Wrapper" output in console after the call with mozilla version. Using this version will be better workaround then using Chrome.

So what could be wrong with openSUSE's FireFox?
The only thing I can think of is a default add-on installed with openSuse's Firefox that could cause this. As you haven't tried in Safe mode, that might be the culprit.
Anyway this would deserve to be reported to your distribution so that they can fix this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

7 years ago
Ok, thanks
Just to let you know, I have filed a bug for openSUSE: https://bugzilla.novell.com/show_bug.cgi?id=749376
You need to log in before you can comment on or make changes to this bug.