Last Comment Bug 723509 - update Unicode support to v6.1
: update Unicode support to v6.1
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Simon Montagu :smontagu
:
Mentors:
http://www.unicode.org/versions/Unico...
Depends on:
Blocks: 725293
  Show dependency treegraph
 
Reported: 2012-02-02 07:09 PST by Jonathan Kew (:jfkthame)
Modified: 2012-02-08 06:42 PST (History)
5 users (show)
smontagu: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (658.40 KB, patch)
2012-02-05 12:46 PST, Simon Montagu :smontagu
jfkthame: review+
Details | Diff | Splinter Review

Description Jonathan Kew (:jfkthame) 2012-02-02 07:09:15 PST
We should update the various data tables, etc., that depend on Unicode, now that v6.1 is officially released.

This mainly affects code/data under intl/, presumably, but also some in gfx/thebes/.
Comment 1 Simon Montagu :smontagu 2012-02-02 08:19:27 PST
https://wiki.mozilla.org/I18n:Updating_Unicode_version
Comment 2 Simon Montagu :smontagu 2012-02-02 08:28:34 PST
In the past we have generally pushed Unicode updates to release branches so that releases support the latest Unicode version. In the rapid-release model, I think we can just let the update ride the trains. As it happens this release will show the longest delay possible if we follow that model: 6.1 support will be in Firefox 13, due for release on 2012-06-05. I think this is a reasonable delay.
Comment 3 Simon Montagu :smontagu 2012-02-05 12:46:41 PST
Created attachment 594584 [details] [diff] [review]
Patch
Comment 4 Jonathan Kew (:jfkthame) 2012-02-06 03:58:55 PST
Comment on attachment 594584 [details] [diff] [review]
Patch

Review of attachment 594584 [details] [diff] [review]:
-----------------------------------------------------------------

rs=jfkthame. I didn't attempt to check all the updates to various generated tables :) but this looks fine.

::: intl/unicharutil/util/nsBidiUtils.h
@@ +278,5 @@
>  #define IS_IN_BMP_RTL_BLOCK(c) ((0x590 <= (c)) && ((c) <= 0x8ff))
>  #define IS_RTL_PRESENTATION_FORM(c) (((0xfb1d <= (c)) && ((c) <= 0xfdff)) || \
>                                       ((0xfe70 <= (c)) && ((c) <= 0xfefc)))
> +#define IS_IN_SMP_RTL_BLOCK(c) (((0x10800 <= (c)) && ((c) <= 0x10fff)) || \
> +                                ((0x1E800 <= (c)) && ((c) <= 0x1EFFF)))

Please use lowercase hex here; consistency with the surrounding code makes it easier to read, IMO.
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-02-06 06:00:15 PST
Tom, does jseng need anything updated?
Comment 7 Tom Schuster [:evilpie] 2012-02-06 06:59:10 PST
I just run js/src/vm/make_unicode.py and indeed it looks like some stuff that is relevant to JS changed. Because I am bit lazy did anything conceptually in Unicode (and or the Unicode format) change? I would guess not.
Comment 8 Jonathan Kew (:jfkthame) 2012-02-06 07:39:09 PST
There'll be a few changes due to new case-mappings, etc., but it looks like re-running make_unicode.py with the latest data file should be all you need.
Comment 9 Ed Morley [:emorley] 2012-02-07 12:19:46 PST
https://hg.mozilla.org/mozilla-central/rev/f5ca692a6763

Note You need to log in before you can comment on or make changes to this bug.