If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

If css opacity is toggled, the element fades to black instead of transparent.

RESOLVED DUPLICATE of bug 723484

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 723484
6 years ago
6 years ago

People

(Reporter: lb, Unassigned)

Tracking

({css2})

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

I set up a page with an image element in it. Through css I specified that the image should fade to opacity 0.2 on hover: img:hover {opacity: 0.2;}



Actual results:

When hovering the mouse over the image, the image fades to black, and switches to 0.2 Tranparency after a short moment.


Expected results:

The image shoul've faded to transparent instead.
(Reporter)

Updated

6 years ago
Keywords: css2

Comment 1

6 years ago
Other reports about this issue:
http://forums.mozillazine.org/viewtopic.php?f=9&t=2417951

See testcases here:
http://jonraasch.com/blog/a-simple-jquery-slideshow
http://slayeroffice.com/code/imageCrossFade/xfade2.html
http://clagnut.com/sandbox/imagefades/
The testcase works fine for me with Seamonkey trunk and FF10.0 on win7/32.
Please test again in the Firefox safemode
http://support.mozilla.com/en-US/kb/Safe+Mode

Comment 3

6 years ago
It sounds like an issue with the HWA in Firefox. Try with the HWA disabled (Options > Advanced > General) in FF10 and make another try.
(Reporter)

Comment 4

6 years ago
I came a bit closer to a solution.

First, here are screenshots of what happens: http://imgur.com/a/rMw1k/embed

The problem appears not to be related to hwa, since turning it of the issue remained unchanged.
After starting FF in -safe-mode, I couldn't reproduce the problem, it all worked as desired. Strange enough, it still works after closing FF -safe-mode and restarting it again in standard mode.

Could this be related to the adblock plus plugin probably?

Comment 5

6 years ago
(In reply to lb from comment #4)
> The problem appears not to be related to hwa, since turning it of the issue
> remained unchanged.
When you disable HWA in Firefox options, you need to restart Firefox to apply the change.

> After starting FF in -safe-mode, I couldn't reproduce the problem, it all
> worked as desired.
Starting Firefox in safe mode disables HWA.

I'm pretty sure if you restart Firefox in normal mode with HWA disabled, opacity will work as expected. Make a try.
This looks like a dupe of bug 723484.
Could you please copy+paste the graphic section from about:support ?
duping to bug 723484.
Please post the graphic card and driver version from about:support to bug 723484
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 723484
(Reporter)

Comment 8

6 years ago
Issue appears to be gone after restarting FF once without hwa, either in -safe-mode or manually toggled off.

graphics card: ATI Radeon HD 5700 Series
Vendor-ID: 1002
device id: 68b8
device RAM: Unknown
device driver: ati2dvag
driver version: 8.771.0.0
driver date: 8-25-2010
You need to log in before you can comment on or make changes to this bug.