When opening all bookmarks from a bookmark folder, the new tabs are not ordered in the same order as the bookmark folder entries.

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: petr.dolezal, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Use "Open all in tabs" menu item in a bookmark folder with multiple bookmarks.


Actual results:

New tabs are opened for all bookmarks in the bookmark folder, but they are not ordered in the same order in which the bookmarks are listed. The tab order seems rather to be random.


Expected results:

The tabs should be opened in the same order as listed in the bookmark folder like Firefox 8 and older versions did. The behaviour changed in Firefox 9, so the tabs don't respect the bookmark order any longer and there is no way (e.g. a configuration option) to enable the original behaviour.
(Reporter)

Updated

7 years ago
Component: Untriaged → Bookmarks & History
works for me
do you have add-ons that may interfere? please try safe mode.
http://support.mozilla.org/kb/safe+mode
(Reporter)

Comment 2

7 years ago
(In reply to Marco Bonardo [:mak] from comment #1)
> works for me
> do you have add-ons that may interfere? please try safe mode.
> http://support.mozilla.org/kb/safe+mode

I'm sorry, my fault - I didn't try the safe mode, which I obviously should. The interferring add-on is Super Tab Mode (https://addons.mozilla.org/en-US/firefox/addon/super-tab-mode/) if anybody was interested.

As I wrote, the interference appeared with the version upgrade. During the experiments with the add-on, I found also another funny interference with yet another add-on when "Don't load tabs until selected" is checked. It seems that changes in the tab area cause some troubles for the add-ons.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
QA Contact: untriaged → bookmarks
You need to log in before you can comment on or make changes to this bug.