Status

RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: akeybl, Assigned: jlong)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
+++ This bug was initially created as a clone of Bug #722741 +++

Clone to fix the UA sniffing issue found in https://bugzilla.mozilla.org/show_bug.cgi?id=722741#c1

Comment 1

7 years ago
Thanks for filing - good to know this is still a open bug - yikes. 

James - can you help out here? If not, I can work with Fred to route elsewhere. Since this is a critical bug, the sooner it's resolved the better.  

I'm putting it into the 1.5 milestone but it can go live earlier than next Tuesday once resolved.
Assignee: nobody → jlong
Target Milestone: --- → 1.5

Updated

7 years ago
Depends on: 706310

Updated

7 years ago
Depends on: 708141

Comment 2

7 years ago
Thanks for filing, I'm adding all the other bugs around UA detection here. They have been piling up.
I cannot confirm the bug for Firefox 10 nor Nightlies. Alex: Why do you think the bug was not fixed properly in bug 722741?
(Reporter)

Comment 4

7 years ago
Anthony (QA) reported the issue

ashughes: akeybl, when I started 11.0b1 today it loaded http://www.mozilla.org/en-US/firefox/11.0/whatsnew/
ashughes: which says "this version is out of date...download Firefox 10"
From email thread:

> This is first time I saw it. This is what I did:
>
> 1) Running Firefox 11 Aurora from a couple days ago
> 2) Download and install Firefox 11b1 candidate
> 3) Start Firefox 11b1 on the same profile
> 4) WN page -> Firefox 11 is out of date, go here to download Firefox 10
(Assignee)

Comment 6

7 years ago
Interesting. Are we sure this paged was being viewed before by beta?

Anyway, we should fix it. I can probably do it before 1.5.
(In reply to James Long (:jlongster) from comment #6)
> Interesting. Are we sure this paged was being viewed before by beta?
> 
> Anyway, we should fix it. I can probably do it before 1.5.

This page was not loaded as part of a previous session, if that's what you are asking...
(Assignee)

Comment 8

7 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #7)
> (In reply to James Long (:jlongster) from comment #6)
> > Interesting. Are we sure this paged was being viewed before by beta?
> > 
> > Anyway, we should fix it. I can probably do it before 1.5.
> 
> This page was not loaded as part of a previous session, if that's what you
> are asking...

No, I meant if previous beta showed this page as the whatsnew page when they were first run. Not a big deal though, we can fix this one.

Comment 9

7 years ago
(In reply to James Long (:jlongster) from comment #8)
> (In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #7)
> > (In reply to James Long (:jlongster) from comment #6)
> > > Interesting. Are we sure this paged was being viewed before by beta?
> > > 
> > > Anyway, we should fix it. I can probably do it before 1.5.
> > 
> > This page was not loaded as part of a previous session, if that's what you
> > are asking...
> 
> No, I meant if previous beta showed this page as the whatsnew page when they
> were first run. Not a big deal though, we can fix this one.

I believe that Beta does have both a First Run and a What's New page live right now - so that could very well be the case. Cc-ing Grace here in case she has insights. 

In any case, should be fixed.

Updated

7 years ago
Blocks: 723720

Updated

7 years ago
No longer depends on: 706310, 708141
(Reporter)

Comment 10

7 years ago
(In reply to James Long (:jlongster) from comment #6)
> Interesting. Are we sure this paged was being viewed before by beta?
> 
> Anyway, we should fix it. I can probably do it before 1.5.

Is there any way to resolve this issue by around noon PT tomorrow? That's the earliest we'd expect our next beta to go out the door. Thanks!
hi all, 

i apologize for chiming in late. 
this is what we had for 10.0 beta.

http://screencast.com/t/cCaBDX0xI

Comment 12

7 years ago
(In reply to Alex Keybl [:akeybl] from comment #10)
> (In reply to James Long (:jlongster) from comment #6)
> > Interesting. Are we sure this paged was being viewed before by beta?
> > 
> > Anyway, we should fix it. I can probably do it before 1.5.
> 
> Is there any way to resolve this issue by around noon PT tomorrow? That's
> the earliest we'd expect our next beta to go out the door. Thanks!

Didn't realize this was a blocker to launch the Beta today. 

James - can you help out here?

Updated

7 years ago
Blocks: 718777
Sorry, I realize now that I have 2 different URLs. To clarify, both the first run page and the what's new page display the same message "Firefox 11 is out of date, please update to Firefox 10".

firstrun is what I get with new install, new profile
whatsnew is what I get if I run a profile in Aurora then switch to Beta on the same profile
The message is the same on both pages.
(Assignee)

Comment 15

7 years ago
The issue is not with US sniffing, it was a problem of communicating which page is loaded when the browser starts (and figuring out which redirects to update).
Severity: critical → normal
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 16

7 years ago
(In reply to James Long (:jlongster) from comment #15)
> The issue is not with US sniffing, it was a problem of communicating which
> page is loaded when the browser starts (and figuring out which redirects to
> update).

Specifically, my understanding is that there was a broken regex in the .htaccess file that had not been uplifted from dev to production (still 2-digit version number related). Thanks for your help James.
(Assignee)

Comment 17

7 years ago
(In reply to Alex Keybl [:akeybl] from comment #16)
> (In reply to James Long (:jlongster) from comment #15)
> > The issue is not with US sniffing, it was a problem of communicating which
> > page is loaded when the browser starts (and figuring out which redirects to
> > update).
> 
> Specifically, my understanding is that there was a broken regex in the
> .htaccess file that had not been uplifted from dev to production (still
> 2-digit version number related). Thanks for your help James.

Yep! The regex itself just needed the number 11 added to it, so it wasn't exact 2 digit related. There are way too much magic redirects in the .htaccess file that we need to update each release.
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.