Closed Bug 723632 Opened 10 years ago Closed 10 years ago

Switch Mac L10N to 10.7 slaves once 10.7 is doing builds.

Categories

(Release Engineering :: General, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 720027

People

(Reporter: jhford, Unassigned)

References

Details

(Whiteboard: [l10n])

Once we start building for Mac on 10.7 slaves, L10N will be one of the only things left to move over to 10.7 slaves before we can turn off the 10.6 build slaves.

I am going to tackle this after the builds.
Summary: Switch Mac L10N to 10.7 slaves once 10.7 slaves → Switch Mac L10N to 10.7 slaves once 10.7 is doing builds.
I think we're probably blocked here on bug 715397 and getting the actual hardware as well.
Depends on: 715397
Priority: -- → P3
Whiteboard: [l10n]
I did some digging into this today.  I've gotten to the point where I am failing to download the en-US binary.  This is because the l10n make files are looking for a .mac64. file instead of a .mac. file.  For whatever reason, configure on the lion slaves is setting TARGET_CPU to x86_64 where it must have set it to something else on 10.6.  Running the configure program with --target=i386-apple-darwin11.2.0 results in autoconf.mk having the correct target architecture.  Existing code allows a per-branch extra configure arguments.  This is fine for branch wide settings, but setting all machine's --target will result in general failure.  I've added support for platform level extra configure arugments.
Sadly, we use sh -- instead of sh -c, so I have to hardcode in darwin11.2.0 instead of using $(uname -r).  

Happily, I was able to go green on a repack of a build that was built on 10.6 http://dev-stage01.build.sjc1.mozilla.com/pub/mozilla.org/firefox/nightly/2012/02/2012-02-17-11-44-51-mozilla-central-l10n

I need to try doing this for a build that was built on 10.7 still
work was done as part of bug 720027
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720027
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.