Improve Admin Add-on search - no more partial word matches (and more)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: eviljeff, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
The current add-on search doesn't function like a 'normal' search does which can make it difficult to find the correct add-on.  The following changes are need:

Search terms should not be broken into subwords, but exact phrases.  Currently a search with 'fire' in it returns thousands of matches, whereas it should only return matches where the exact phrase is in it.  E.g. [Fireshot] should match [Fireshot 123] but not [Fire Shot] or [Firebug]

Phrases wrapped in double quotes should be searched exactly as exact phrases regardless of spaces.  E.g. ["Fire shot"] should match [Fire shot 123] but not [FireShot]

Multiple search terms, separated by spaces, should return matches where all terms are present.  E.g. [Fire shot] should only return matches that contain both words such as [Fireshot] [Fire shot] [Firefox shot] but not [Firebug]
Duping to the request for search spec.  These bugs come up occasionally with specific examples but without a spec it feels like we chase around these bugs changing functionality every few months.  There are some other bugs we should dupe onto that also to get them all in one place.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 572453
(Reporter)

Comment 2

7 years ago
de-duping as bug 572453 is a spec for the public search - this is the admin search.  Let me know if there is a specific format for the spec you need.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Having the admin search behave differently than the regular search[1] sounds like complexity on the developer side and confusion on the users' side.  For the spec I'm looking for the default returned ordering, the fields being looked at, and then any additional rules or weightings.  I don't have a specific format.

[1] Aside from showing disabled add-ons, of course
(Reporter)

Comment 4

7 years ago
-Admin Search Spec-

Scope: 
all addons, including personas and search engines - basically anything with a /slug/ ; status should be ignored (i.e. include admin disabled and incomplete).  I don't believe this is a change from the current method.

Default results order:
alphabetically by name in en-US locale (or default if no name entry in en-US locale). Ideally any result that *exactly* matched the search string would be promoted to first place. No other weighting.

Fields searched:
slug; name in all locales. Just a normal substring search within the fields.

Query string:
search terms separated by spaces, except where enclosed within double quotes when everything between the quote marks should be taken as a single term.

Matches:
return where each search term is matched in at least one field. (AND search)

--

The only thing I'm unsure about is whether we want apps included in the same search or whether you have implemented (or plan to implement) to separate admin app search.  Either is fine but we might need a way of filtering the results if the number of matches is going to grow significantly (separate bug).
That looks good. I'd suggest adding a dropdown where we can choose Add-ons, Apps, or Personas for the search. Both Apps and Personas would pollute the results too much, IMO.
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
Closing in favor of https://github.com/mozilla/addons-server/issues/978
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.