drop nightly prod DB dump on graphs1.stage.dmz.sjc1.mozilla.com

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: rhelmer, Assigned: scabral)

Tracking

Details

(Reporter)

Description

7 years ago
Right now, there is a nightly dump from the production graphserver database automatically imported to:

host: tm-stage01-master01
db: graphs_stage2_prod

It would be very useful to have a copy of this dump available for development purposes.

Would it be possible to copy the dump that's already being generated to graphs1.stage.dmz.sjc1.mozilla.com ? We only need one copy, so just copying over the same file would be fine.


Thanks!
(Assignee)

Comment 1

7 years ago
I'm testing out a script on this now, the same script that copies to tm-stage01-master01 seems to be working to copy to graphs1.stage.dmz.sjc.mozilla.com, but I won't know for sure until it's done.
(Assignee)

Comment 2

7 years ago
The script was successful - can you confirm that you can use the *.sql.gz files that are on server:folder - 

graphs1.stage.dmz.sjc1.mozilla.com:/data/backup-drop/b01/mysql/graphs_mozilla_org_new/

??

If so, I'll put it as part of a cron script and it will be automated.
Status: NEW → ASSIGNED
I can confirm, I was able to copy graphs1.stage.dmz.sjc1.mozilla.com:/data/backup-drop/b01/mysql/graphs_mozilla_org_new/ locally and build a MySQL database that's working great.  Thanks for your help.
(Assignee)

Comment 4

7 years ago
awesome, I'll leave this open for at least another day so we can confirm the cron script works.
(Assignee)

Updated

7 years ago
Assignee: server-ops-database → scabral
(Assignee)

Comment 5

7 years ago
Checking, for some reason the cron script isn't working.  I'm debugging now.
(Assignee)

Comment 6

7 years ago
Cron script is working again (and has been for a while). Resolving.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Data & BI Services Team
You need to log in before you can comment on or make changes to this bug.