Closed Bug 723899 Opened 8 years ago Closed 8 years ago

android.view.InflateException: Binary XML file line #7: Error inflating class <unknown>: at android.view.LayoutInflater.createView(LayoutInflater.java)

Categories

(Firefox for Android :: General, defect, P1, critical)

12 Branch
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 13
Tracking Status
firefox11 --- verified
firefox12 --- verified
firefox13 --- verified

People

(Reporter: scoobidiver, Assigned: sriram)

References

Details

(4 keywords, Whiteboard: [native-crash])

Crash Data

Attachments

(2 files)

It's #1 top crasher in 12.0a2.

It first appeared in 12.0a2/20120202194935 and 13.0a1/20120202091519.
The m-c regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e18c7bc2c28e&tochange=411f1ddbccb9
Steps to reproduce:
1. Install Aurora build
2. Enter application - > Tab URL bar

Issue reproducible on all devices with Android >= 2.3 (excluding Google Nexus S). Not reproducible on Android 2.2
Keywords: reproducible
I can reproduce this using this inbound build from today on my Galaxy Nexus (Android 4.0.2)

20120203060229
http://hg.mozilla.org/integration/mozilla-inbound/rev/137e8fbde75a
tracking-fennec: --- → ?
Attached file log
Assignee: nobody → sriram
Priority: -- → P1
Attached patch PatchSplinter Review
There is no resource named "empty" in ICS. Also, an "id" is being referenced for a "drawable". By default, if the "src" is not specified, that particular row's favicon is transparent already. To make it transparent in the Java code, we need to use setImageDrawable(null).
Attachment #594250 - Flags: review?(mark.finkle)
Attachment #594250 - Flags: review?(mark.finkle) → review+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Version: Firefox 12 → Firefox 13
Target Milestone: --- → Firefox 13
Version: Firefox 13 → Firefox 12
Comment on attachment 594250 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): bug 719900
User impact if declined: Bad things
Testing completed (on m-c, etc.): on m-c now. needs to be verified
Attachment #594250 - Flags: approval-mozilla-beta?
Attachment #594250 - Flags: approval-mozilla-aurora?
Comment on attachment 594250 [details] [diff] [review]
Patch

[Triage Comment]
Approved for Aurora and Beta.
Attachment #594250 - Flags: approval-mozilla-beta?
Attachment #594250 - Flags: approval-mozilla-beta+
Attachment #594250 - Flags: approval-mozilla-aurora?
Attachment #594250 - Flags: approval-mozilla-aurora+
The bug is not reproducible on Firefox Beta 11 (20120206202409)
Device: Samsung Galaxy SII, Android 2.3.4
Verified Fixed on M-C & M-A
Tested via Galaxy Nexus (Android 4.0.2)
Mozilla/5.0 (Android; Mobile; rv:12.0a2) Gecko/12.0a2 Firefox/12.0a2
Mozilla/5.0 (Android; Mobile; rv:13.0a1) Gecko/13.0a1 Firefox/13.0a1
Status: RESOLVED → VERIFIED
Duplicate of this bug: 725027
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.