add mozilla-esr10 to production-branches.json (and maybe self serve?)

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
Rebuild request for Linux Build opt failed. (TypeError: builds.filter is not a function)
Did you mean this to be "there should be a better error message for retriggers on branches that aren't yet added to self-serve" or just "add mozilla-esr10 to self-serve"?
(Assignee)

Comment 2

6 years ago
Probably the latter. Chris, does self serve feed off of production-branches.json?
Summary: rebuilds for mozilla-esr10 branch fail with weird error → add mozilla-esr10 to production-branches.json (and maybe self serve?)
(Assignee)

Updated

6 years ago
Assignee: nobody → bhearsum
(In reply to Ben Hearsum [:bhearsum] from comment #2)
> Probably the latter. Chris, does self serve feed off of
> production-branches.json?

No, not yet.
Duplicate of this bug: 725190
I updated self-serve and succesfully triggered a rebuild of a job using tbpl.
Created attachment 595287 [details] [diff] [review]
[puppet-manifests] Sync up branch list with cruncher

We don't have the latest twigs on buildapi01 at the moment.
Attachment #595287 - Flags: review?(catlee)

Updated

6 years ago
Attachment #595287 - Flags: review?(catlee) → review+
Comment on attachment 595287 [details] [diff] [review]
[puppet-manifests] Sync up branch list with cruncher

http://hg.mozilla.org/build/puppet-manifests/rev/f74e9363affa

Deployed on master-puppet1 and buildapi01.build.m.o. Docs at https://wiki.mozilla.org/ReleaseEngineering/How_To/Restart_BuildAPI#Restarting_the_buildapi_web_app updated.
Attachment #595287 - Flags: checked-in+
Leaving open for production-branches.json.
(Assignee)

Comment 10

6 years ago
Created attachment 595435 [details] [diff] [review]
add to production-branches.json

Thanks for taking care of self serve/buildapi!
Attachment #595435 - Flags: review?(catlee)

Updated

6 years ago
Attachment #595435 - Flags: review?(catlee) → review+
(Assignee)

Updated

6 years ago
Attachment #595435 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.