Message Filters drop conditions after fourth condition

VERIFIED DUPLICATE of bug 40480

Status

MailNews Core
Filters
VERIFIED DUPLICATE of bug 40480
17 years ago
10 years ago

People

(Reporter: gekacheka, Assigned: gayatrib)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1) Gecko/20010316
BuildID:    2001031604

If you add more than 4 conditions to a filter, they appear ok while editing, but
after closing the filter dialog, 
 - if you open it again, the condition lines after the first 4 don't contain any
text, and 
 - the conditions after the first 4 don't affect message filtering.

Reproducible: Always
Steps to Reproduce:
1. create a 'test' filter with 4 conditions
2. close filter dialog, "OK' to top level.
3. open filter dialog, edit the 'test' filter, add more conditions
4. close filter dialog, 'OK' to top level.
5. open filter dialog, edit the same filter again.


Actual Results:  Conditions after the fourth do not appear correctly (no text).
They do not operate correctly either.
(i.e., messages are not effectively filtered by conditions after the fourth.)

Expected Results:  All conditions should appear as they did 
when they were entered/edited.

All conditions should be effective for filtering messages.

(Alternative:  don't allow user to add more than 4 conditions.
 but I don't see any reason for this restriction)

Workaround:  split filters with more than 4 (OR) conditions into two filters,
e.g., junkmail-filter, junkmail-filter2.  (No workaround for AND conditions.)

Comment 1

17 years ago
Confirming on 2001031604 Win2k build.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Laurel, I think this is a dup of an XPToolkit bug.

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 40480 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
QA Contact: esther → laurel
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified as a duplicate
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

17 years ago
In 2001050420 this problem is worse:  filters now drop conditions after third
condition.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.