Exception is thrown when showing statistics on a loading video

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: diogogmt, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 1270853])

Steps to reproduce:

1 - Open a video or a page with a video embedded
2 - Click on the play button
3 - Right click on the video and click on Show Statistics
4 - Will throw exception

Test Page - http://diogogmt.github.com/mozilla-central/gizmo.webm

**this bug only happens in a slow network connection

DUMP:
videoctl: Got media event ----> play
videoctl: Status overlay: seeking=false error=null readyState=0 paused=false ended=false networkState=2 timeUpdateCount=0 --> SHOW
videoctl: Got media event ----> waiting
videoctl: Status overlay: seeking=false error=null readyState=0 paused=false ended=false networkState=2 timeUpdateCount=0 --> SHOW
JavaScript error: , line 0: uncaught exception: [Exception... "An attempt was made to use an object that is not, or is no longer, usable"  code: "11" nsresult: "0x8053000b (NS_ERROR_DOM_INVALID_STATE_ERR)"  location: "chrome://global/content/bindings/videocontrols.xml Line: 1097"]
JavaScript error: , line 0: uncaught exception: [Exception... "An attempt was made to use an object that is not, or is no longer, usable"  code: "11" nsresult: "0x8053000b (NS_ERROR_DOM_INVALID_STATE_ERR)"  location: "chrome://global/content/bindings/videocontrols.xml Line: 1097"]

It seems that the problem is happening because the mozChannels attribute is being accessed in the updateStats method in the videocontrols.xml
If a decoder or an audio stream doesn't exist the nsHTMLMediaElement::GetMozChannels returns NS_ERROR_DOM_INVALID_STATE_ERR

Should a check be added before trying to get the mozChannles or the exception is being thrown for a reason here?
Component: General → Video/Audio Controls
Product: Firefox → Toolkit
QA Contact: general → video.audio
Fixed via fixing bug 1270853.
Whiteboard: [fixed by bug 1270853]
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.