Empty bookmark folders hangs browser on next add.

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: malinon, Assigned: bugs)

Tracking

({hang})

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When I updated my browser to the Win32 build 2001031604, I managed to lose all
of my bookmarks the next time I attempted to add a bookmark.

While that is a vague statement, I may have encountered at least part of the
reason while attempting to rebuild my bookmark file.  It appears that Mozilla is
not allowing empty folder levels in the bookmark tree.  See reproduction
instructions for clarification:

1)  Before you start Mozilla, delete the current bookmarks.html for the current 
    profile.
2)  Start Mozilla (I am currently using build 2001031604)
3)  Open the bookmark manager.
4)  Create a folder called 'Entertainment'
5)  Create a folder called 'Humor'  Move this folder into the 'Entertainment'
    folder.
6)  Create a folder called 'Comics'  Move this folder into the 'Humor' subfolder
    of 'Entertainment'
7)  From the browser window, add a bookmark, and create it in the 'Comics' 
    folder (I used http://www.userfriendly.org/)
8)  Now attempt to add another bookmark.  Browser locks up for me 100% of the 
    time.

Comment 1

18 years ago
Adding crash keyword.
Keywords: crash

Comment 2

18 years ago
Changing "crash" to "hang" in summary and keywords after reading the description
more thoroughly.

Following your steps, I cannot reproduce this on 2001031604 Win2k.
Keywords: crash → hang
Summary: Empty bookmark folders crash browser on next add. → Empty bookmark folders hangs browser on next add.

Comment 3

18 years ago
Reporter, is this still an issue with a current build? (Mozilla 0.8.1+)
(Reporter)

Comment 4

18 years ago
I can't check on Windows ME at the moment, as my motherboard has gone south and 
is in the process of getting replaced.  I will check as soon as I have an 
opportunity.

Comment 5

18 years ago
Marking WORKSFORME: I cannot duplicate the issue.

Reporter: If you are able to again test this and find it still an issue, post
your findings to this bug and we'll reopen it if necessary.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
My computer is back from the dead and I have verified that this issue is resolved.
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.