Last Comment Bug 724146 - IonMonkey: Fix invalidation crash on x64
: IonMonkey: Fix invalidation crash on x64
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 All
: -- normal (vote)
: ---
Assigned To: David Anderson [:dvander]
:
:
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2012-02-03 15:46 PST by David Anderson [:dvander]
Modified: 2012-02-03 16:13 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (989 bytes, patch)
2012-02-03 15:47 PST, David Anderson [:dvander]
cdleary: review+
Details | Diff | Splinter Review

Description David Anderson [:dvander] 2012-02-03 15:46:35 PST
jit-test/tests/basic/testArrayDensityChange.js is failing because invalidation clobbers |rax| which holds the return value of an out-of-line GETPROP.
Comment 1 David Anderson [:dvander] 2012-02-03 15:47:12 PST
Created attachment 594336 [details] [diff] [review]
fix
Comment 2 David Anderson [:dvander] 2012-02-03 16:13:35 PST
https://bugzilla.mozilla.org/show_bug.cgi?id=724146

Note You need to log in before you can comment on or make changes to this bug.