Internal error: null plugin manager

RESOLVED WONTFIX

Status

P1
critical
RESOLVED WONTFIX
18 years ago
8 years ago

People

(Reporter: xalkina, Assigned: edburns)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This is the configuration:
mozilla/2001031611 (and previous builds as well) under linux
N6/Java2 plugin

This is what happens:
Visiting the chat-sites linked in URL, mozilla crashes saying "Internal error:
Null plugin manager" on its console
It does not exactly reproducible, but it always happens after some back and
forth to the pages that contain the applets.

Comment 1

18 years ago
Adding crash keyword.
Keywords: crash

Comment 2

18 years ago
oji
Assignee: av → edburns
Component: Plug-ins → OJI

Comment 3

18 years ago
Confirming for Linux build 2001032021, Linux 2.4.2-ac20 i686, RedHat 6.1;
increasing severity to critical.

I got the following stack trace from such a crash:

#0  0x40e15416 in JavaPluginInstance5::SetWindow ()
   from java2/plugin/i386/ns600/libjavaplugin_oji.so
#1  0x40d5f1af in nsPluginHostImpl::InstantiateEmbededPlugin ()
   from mozilla/components/libgkplugin.so
#2  0x4100f821 in nsObjectFrame::InstantiatePlugin ()
   from mozilla/components/libgklayout.so
#3  0x4100eaff in nsObjectFrame::Reflow ()
   from mozilla/components/libgklayout.so
#4  0x4100a9c8 in nsLineLayout::ReflowFrame ()
   from mozilla/components/libgklayout.so
#5  0x40feac5d in nsBlockFrame::ReflowInlineFrame ()
   from mozilla/components/libgklayout.so
#6  0x40feaaa7 in nsBlockFrame::DoReflowInlineFrames ()
   from mozilla/components/libgklayout.so
#7  0x40fea916 in nsBlockFrame::DoReflowInlineFramesAuto ()
   from mozilla/components/libgklayout.so
#8  0x40fea7db in nsBlockFrame::ReflowInlineFrames ()
   from mozilla/components/libgklayout.so
#9  0x40fe9548 in nsBlockFrame::ReflowLine ()
   from mozilla/components/libgklayout.so
#10 0x40fe8e6a in nsBlockFrame::ReflowDirtyLines ()
   from mozilla/components/libgklayout.so
#11 0x40fe79f5 in nsBlockFrame::Reflow ()
   from mozilla/components/libgklayout.so
#12 0x40feedbd in nsBlockReflowContext::DoReflowBlock ()
   from mozilla/components/libgklayout.so
#13 0x40fee8c0 in nsBlockReflowContext::ReflowBlock ()
   from mozilla/components/libgklayout.so
#14 0x40fea1ff in nsBlockFrame::ReflowBlockFrame ()
   from mozilla/components/libgklayout.so
#15 0x40fe9232 in nsBlockFrame::ReflowLine ()
   from mozilla/components/libgklayout.so
#16 0x40fe8e6a in nsBlockFrame::ReflowDirtyLines ()
   from mozilla/components/libgklayout.so
#17 0x40fe79f5 in nsBlockFrame::Reflow ()
   from mozilla/components/libgklayout.so
#18 0x40ff1863 in nsContainerFrame::ReflowChild ()
   from mozilla/components/libgklayout.so
#19 0x40ffd5bc in CanvasFrame::Reflow ()
   from mozilla/components/libgklayout.so
#20 0x40ff1863 in nsContainerFrame::ReflowChild ()
   from mozilla/components/libgklayout.so
#21 0x4102cb6b in ViewportFrame::Reflow ()
   from mozilla/components/libgklayout.so
#22 0x40ffe9cd in nsHTMLReflowCommand::Dispatch ()
   from mozilla/components/libgklayout.so
#23 0x4101c579 in PresShell::ProcessReflowCommand ()
   from mozilla/components/libgklayout.so
#24 0x4101c6f6 in PresShell::ProcessReflowCommands ()
   from mozilla/components/libgklayout.so
#25 0x4101c34f in HandlePLEvent ()
   from mozilla/components/libgklayout.so
#26 0x400c18b7 in PL_HandleEvent () at eval.c:41
#27 0x400c17d6 in PL_ProcessPendingEvents () at eval.c:41
#28 0x400c26b9 in nsEventQueueImpl::ProcessPendingEvents () at eval.c:41
#29 0x404d90f3 in event_processor_callback ()
   from mozilla/components/libwidget_gtk.so
#30 0x404d8e6d in our_gdk_io_invoke ()
   from mozilla/components/libwidget_gtk.so
#31 0x406b1040 in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#32 0x406b2847 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#33 0x406b2ec1 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#34 0x406b308c in g_main_run () from /usr/lib/libglib-1.2.so.0
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
*** Bug 73388 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

18 years ago
Java doesn't run in last week's trunk build, rebuilding.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

18 years ago
*** Bug 72663 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

18 years ago
I get a crash on the gogreece chat.  P1
Priority: -- → P1
(Assignee)

Comment 8

18 years ago
Now I'm seeing that the applet loads, but I get the dreaded ClassFormatError 
bug.  This means the applet must be re-compiled with a Java2 series compiler.  
Please see bug 62025 for more details.

The Java Plugin team has decided not to fix this class of bugs.  Marking 
WONTFIX.



java.lang.ClassFormatError: MSChat (Local variable name has bad constant pool 
index)
	at java.lang.ClassLoader.defineClass0(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:486)
	at java.security.SecureClassLoader.defineClass
(SecureClassLoader.java:111)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
	at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:128)
	at sun.plugin.security.PluginClassLoader.findClass
(PluginClassLoader.java:221)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:297)
	at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:108)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
	at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:366)
	at sun.applet.AppletPanel.createApplet(AppletPanel.java:579)
	at sun.plugin.AppletViewer.createApplet(AppletViewer.java:1157)
	at sun.applet.AppletPanel.runLoader(AppletPanel.java:515)
	at sun.applet.AppletPanel.run(AppletPanel.java:293)
	at sun.plugin.navig.motif.MotifAppletViewer.maf_run
(MotifAppletViewer.java:127)
	at sun.plugin.navig.motif.MotifAppletViewer.run
(MotifAppletViewer.java:123)
	at java.lang.Thread.run(Thread.java:484)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 9

17 years ago
SPAM: reassigning OJI bugs to new QA, pmac. (227 bugs)
QA Contact: shrir → pmac

Updated

16 years ago
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.