[crash nsURIHashKey::HashKey] Crashes When Changing Profiles

RESOLVED DUPLICATE of bug 548685

Status

--
critical
RESOLVED DUPLICATE of bug 548685
7 years ago
7 years ago

People

(Reporter: david, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
This bug was filed from the Socorro interface and is 
report bp-04b0c229-39ef-4691-8921-7bc402120204 .
============================================================= 
Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20120129 SeaMonkey/2.7

SeaMonkey seems to crash occasionally when switching profiles.  My three most recent crash reports (listed below by ID) have been for this problem.  Note that the earliest of the three was for SeaMonkey 2.4 while the most recent is for SeaMonkey 2.7.  

In this latest instance, my home page for the current profile was a local HTML file generated by exporting that profile's bookmarks.  Similarly, the home page for the requested profile was a local HTML file generated by exporting that profile's bookmarks.  My bookmarks are automatically exported upon terminating SeaMonkey.  

Crash reports (most recent is first):
bp-04b0c229-39ef-4691-8921-7bc402120204
PMbp-64c70144-d14d-4189-81d7-f13992120102
PMbp-f73ed004-8a59-419c-b3fe-f35bc2111120

Comment 1

7 years ago
This appears to be a duplicate of Bug 548685 - null dereference topcrash [@ nsURIHashKey::HashKey(nsIURI const*) ] [@ nsTHashtable<mozilla::places::History::KeyClass>::s_HashKey(PLDHashTable*, void const*) ]

But I'm CC'ing Neil as he fixed several similar bugs in MailNews Core.
(Reporter)

Comment 2

7 years ago
This might indeed be a duplicate of bug 548685.  Reading the description and comments in that bug report, however, does not convey in simple terms the description I give here.  

Furthermore, the comments in bug 548685 seem to address a problem where home pages are external to the client host, must be fetched from a Web server, and might be 404.  In my case, the problem involves home pages that are internal to my client host, must be fetched from my hard drive, and are definitely not 404.

Comment 3

7 years ago
These breakpad reports refer to a shutdown crash, not a startup crash, so I agree that this is a duplicate of bug 548685.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548685
You need to log in before you can comment on or make changes to this bug.