[OpenSearch]: Fix unnecessary and unlocalizable "Search the web" string

RESOLVED FIXED in Thunderbird 24.0

Status

Thunderbird
Search
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Nomis101, Assigned: sshagarwal)

Tracking

11 Branch
Thunderbird 24.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][mentor=mkmelin][string change only], URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 594504 [details]
Screenshot

"Search the web" is not localizable:
http://hg.mozilla.org/comm-central/file/77d2995562e0/mail/base/content/mailWindowOverlay.xul#l614
Which leads in some cases to a mixed rightclick menu.

Comment 1

5 years ago
This isn't actually an issue (except for overall cleanliness) since the label is always set here: http://mxr.mozilla.org/comm-central/source/mail/base/content/nsContextMenu.js#189

Comment 2

5 years ago
Yes, I've noticed that as well and figured that it's just a fallback if the string isn't defined otherwise. Do you see any cases where it actually shows up?

Comment 3

5 years ago
(hmm, judging from the screen shot apparently it /may/ show up...)

Those strings are defined in http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/glodaComplete.properties#54

Comment 4

5 years ago
Nomis101, what did you right click on to get that popup? Nothing I've clicked on looks like that. I'm guessing the entries are "Paste", "Select All", "Check Spelling", "Add to Dictionary", and "Reply", but I can't get a context menu that looks anything like that.

Comment 5

5 years ago
Ohhh, wait, you're doing this from a standalone message window (in 11.0), right? In that case, this is a dupe of bug 720420.
(Reporter)

Comment 6

5 years ago
(In reply to Jim Porter (:squib) from comment #5)
> Ohhh, wait, you're doing this from a standalone message window (in 11.0),
> right? In that case, this is a dupe of bug 720420.

Yes, I also hit bug 720420 in that contextual menu.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720420

Comment 7

5 years ago
Actually, let's undupe this and morph it into a bug for getting rid of that bogus unlocalized string entirely.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: [OpenSearch]: "Search the web" is not localizable → [OpenSearch]: Remove unnecessary and unlocalizable "Search the web" string
Status: REOPENED → NEW
Whiteboard: [good first bug]

Updated

4 years ago
OS: Mac OS X → All
Hardware: x86 → All

Comment 8

4 years ago
http://hg.mozilla.org/comm-central/annotate/1b9445a7c2dc/mail/base/content/mailWindowOverlay.xul#l610
Whiteboard: [good first bug] → [good first bug][mentor=mkmelin][string change only]
(Assignee)

Comment 9

4 years ago
Sir,

I tried to reproduce the problem following the steps to reproduce as mentioned here:

https://bugzilla.mozilla.org/show_bug.cgi?id=720420#c0

But, I was unable to find "Search the web" option in the context menu. And, when I selected a piece of text, then the right-click context menu contained the option "Search Bing for:<selected_string>", but there was no option as "Search the web"

So, please tell me how to reproduce the error.
Flags: needinfo?(mkmelin+mozilla)

Comment 10

4 years ago
Yeah the "Search the web" should never really show up anywhere, it's always replaced with a "Search Bing......" before showing - http://mxr.mozilla.org/comm-central/source/mail/base/content/nsContextMenu.js#166

Thinking about it, maybe it's better to just change it to label="[glodaComplete.webSearch1.label]" as a placeholder instead of removing it. That way it's easier to find out what's going on.
Flags: needinfo?(mkmelin+mozilla)
(Assignee)

Comment 11

4 years ago
Created attachment 751473 [details] [diff] [review]
Patch

I have made the change.
Assignee: nobody → syshagarwal
Status: NEW → ASSIGNED
Attachment #751473 - Flags: feedback?(mkmelin+mozilla)

Comment 12

4 years ago
Comment on attachment 751473 [details] [diff] [review]
Patch

Review of attachment 751473 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!
Attachment #751473 - Flags: feedback?(mkmelin+mozilla) → feedback+

Updated

4 years ago
Summary: [OpenSearch]: Remove unnecessary and unlocalizable "Search the web" string → [OpenSearch]: Fix unnecessary and unlocalizable "Search the web" string
(Assignee)

Updated

4 years ago
Attachment #751473 - Flags: review?(mkmelin+mozilla)

Comment 13

4 years ago
Comment on attachment 751473 [details] [diff] [review]
Patch

Review of attachment 751473 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!
Attachment #751473 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/aed39342a55a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 24.0
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.