Last Comment Bug 724363 - Empty <div> with 3D transforms are not rendered if their transformStyle property is set to "perserve-3d", even if size and background is defined in the stylesheet
: Empty <div> with 3D transforms are not rendered if their transformStyle prope...
Status: RESOLVED DUPLICATE of bug 702375
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: 10 Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 724364 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-05 04:56 PST by boblemarin
Modified: 2012-02-05 09:46 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screen capture of my jsfiddle (288.05 KB, image/png)
2012-02-05 04:56 PST, boblemarin
no flags Details

Description boblemarin 2012-02-05 04:56:05 PST
Created attachment 594535 [details]
screen capture of my jsfiddle

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

I define in my CSS a DIV with width and height and background-image.
That DIV has also a 3D transform, and its -moz-transform-style is set to "preserve-3d"

See there in action : http://jsfiddle.net/98cCs/6/


Actual results:

The div does not show up.


Expected results:

The div should appear and have the size and image defined in the CSS.
Comment 1 Bill Gianopoulos [:WG9s] 2012-02-05 05:13:00 PST
*** Bug 724364 has been marked as a duplicate of this bug. ***
Comment 2 Boris Zbarsky [:bz] 2012-02-05 06:04:11 PST
Thank you for reporting the bug!  I see the problem in Firefox 10, but a current nightly works fine. 

Checking some nightlies, looks like this was fixed by bug 702375.  That fix will appear in Firefox 11.

*** This bug has been marked as a duplicate of bug 702375 ***
Comment 3 boblemarin 2012-02-05 09:46:18 PST
Thanks for the info. I checked in the nightly, and it's fine.

Note You need to log in before you can comment on or make changes to this bug.