App tab acts incorrectly when setAttribute("pinned", true) is called

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: fx4waldi, Unassigned)

Tracking

13 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0a1) Gecko/20120204 Firefox/13.0a1
Build ID: 20120204040234

Steps to reproduce:

1. Open some new tabs
2. Using javascript, change the attribute pinned of one of the tabs (e.g. setAttribute("pinned", true); )


Actual results:

pinned tab looks like App tab, but does not behave like App tab.


Expected results:

Tab should behave like any other App tab

Comment 1

6 years ago
(In reply to fx4waldi from comment #0)

> 2. Using javascript, change the attribute pinned of one of the tabs (e.g.
> setAttribute("pinned", true); )
> 

How do I do this?
(Reporter)

Comment 2

6 years ago
experimented with some extension, and I wanted to after pressing the button that opens a new tab is pinned.
So I decided to open a new tab and change the attribute pinned="true"
I think they look like the code
 getMainWindow().getBrowser().addTab(site.url).setAttribute("pinned", true) 

It is a bit incorrect solution because I found pinTab() which works fine. But I think that bug and it should be resolved.

Updated

6 years ago
Component: Untriaged → Tabbed Browser
QA Contact: untriaged → tabbed.browser
Summary: App tab should always be left → App tab acts incorrectly when setAttribute("pinned", true) is called
You need to use pinTab. setAttribute isn't a supported way to do this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.