Pasting a folder in Manage Bookmarks results in 2 folders being pasted

VERIFIED FIXED in mozilla0.9.7

Status

P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: cplyon, Assigned: paulkchen)

Tracking

Trunk
mozilla0.9.7
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to Reproduce:
Create a New Folder in the Manage Bookmarks window.
Cut or Copy said folder.
Paste.

Result:
The folder gets correctly pasted, although under the location column is garbage
Also, an empty folder called "Bookmarks for default" gets created at the bottom.

Don't try moving a bookmark or folder into that empty "Bookmarks for default" 
folder, otherwise that bookmark or folder will disappear.
(Reporter)

Comment 1

18 years ago
Using build 2001041004

Pasting a folder still leaves garbage characters in the location field for that 
new folder and creates an extra folder with the same name as the parent 
folder.  

Upon restarting Mozilla, the extra folder now has the same name as the pasted 
folder, and garbage characters in the location field.
(Reporter)

Comment 2

18 years ago
Using build 2001050904 on Win2K  I can no longer reproduce this bug
(Reporter)

Comment 3

18 years ago
As of build 2001060308 on Win2K:


Pasting a folder resutls in 2 folders being pasted:
The proper folder and the parent folder.
Upon restarting Mozilla, the parent folder gets renamed to the folder that was
pasted.  

For example, when pasting a New Folder into the Mozilla directory:

+Mozilla
    New Folder (pasted)
    Mozilla (duplicate folder)


Changing summary to reflect new behaviour.

Summary: Pasting a folder in Manage Bookmarks problems → Pasting a folder in Manage Bookmarks results in 2 folders being pasted

Comment 4

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ui

Comment 5

18 years ago
exactly the same behaviour when pasting on build 2001061706 on Linux.
This seems to be a general problem, and not just on Win2K
(Reporter)

Comment 6

18 years ago
Changing OS to All based on Erich Kutschinski's comments.
OS: Windows 2000 → All
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.7
(Reporter)

Comment 7

17 years ago
This looks fixed due to Ben's checkin for bug 96824.
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
(Reporter)

Comment 9

17 years ago
*** Bug 106921 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

17 years ago
Fixed by bug 96824.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.