Closed Bug 724491 Opened 8 years ago Closed 8 years ago

Slideshow opacity and stacking order suddenly broken (10.0)

Categories

(Firefox :: Untriaged, defect)

10 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 723484

People

(Reporter: crmathew, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Updated to Firefox 10.0





Actual results:

A long-running JS/CSS slideshow that fades between images has changed behaviour on update to Firefox 10.0. The fade effect is broken: instead of each slide fading out nicely into the next image, the current image simply drops to black, and then the next slide fades in from black. The last slide behaves differently. On all the Firefox 10.0 installations I can find (except my Linux test box and 1 other windows machine, strangely enough) this new behaviour applies.

It is the major image slideshow on this page:
  http://www.computamaps.com/



Expected results:

On all previous versions of Firefox before 10.0, and also IE and Chrome display the desired behaviour of images fading into each-other smoothly.
I see there are lots of complexities to stacking contexts and opacity, both in the CSS specs and many bugs marked "invalid" in this bugzilla, so my slideshow implementation might be flawed, but then all the other browsers and older firefox versions must have been "compensating" for me somehow. What has changed? HW accelerated compositing? Following CSS closer to the letter?
Ah. I've just tested disabling hardware acceleration in the Tools->Options dialog and the issue goes away.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 723484
You need to log in before you can comment on or make changes to this bug.