"Mark Newsgroup read" in context menu stopped working

VERIFIED FIXED in mozilla0.9.1

Status

P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: spam, Assigned: sspitzer)

Tracking

Trunk
mozilla0.9.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

18 years ago
linux 20010318
Select a newsgroup with unread messages
Right-click to bring up context-menu
Select "Mark newsgroup read"

Result: Count remains as it was - neither folder nor messages are indicated as
marked read. On next startup of mailnews, the unread messages are still unread.

Updated

18 years ago
Keywords: nsCatFood

Comment 1

18 years ago
Build 2001-03-19-12: NT4, Mac 9.04
Also a problem on Windows and Mac.
QA Contact: esther → stephend
Hardware: PC → All
*** Bug 72777 has been marked as a duplicate of this bug. ***
Blocks: 72338
Keywords: nsbeta1
OS: Linux → All

Comment 3

18 years ago
marking nsbeta1+
Priority: -- → P3
Whiteboard: [nsbeta1+]

Updated

18 years ago
Target Milestone: --- → mozilla0.9.1

Comment 4

18 years ago
I see that this is targetted for mozilla0.9.1 but I still want to nominate it
for mozilla 0.9. I do this because "Mark Newsgroup read" is the only way I know
of to zero the unread count when it is out of sync with reality. Since the
unread count is wrong I can't navigate with the SPACE (or N - Next message). 
Keywords: mozilla0.9
I'm wondering if this is more label/value fallout?
fixed.

no, this is not label/value fallout.

I forgot to re-implement a function after the mailnews perf landing.

there is a minor bug that I found now that it works.  see bug #74835
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Verified Fixed.  Marking newsgroups works with both the context menu and the
Message | Mark menu.  Restarting Mozilla keeps the same message read status.
2001-04-06-05 Mandrake 7.2 with KDE 2
2001-04-06-08 Mac OS 9.1
2001-04-06-00 (Fresh CVS pull @4:45 PST) on Windows 2000.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.