messages appear double after compacting.

VERIFIED DUPLICATE of bug 66795

Status

VERIFIED DUPLICATE of bug 66795
18 years ago
11 years ago

People

(Reporter: rein, Assigned: naving)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
After compacting e.g. Inbox all messages not in the compact-process before,
are appearing double in the folder. Clicking one of them results in viewing the
real message, clicking the other gives an error.

Only remedy is to delete the corresponding Inbox.msf file.

In my opinion this bug has to do with bugs 68875 and 63673 as well.
Compacting and emptying Trash does not work properly and without failures.
It worked in M 0.7, but not any more in M 0.8

Comment 1

18 years ago
This happens to me too on Windows 95 with build 2001031604

After compacting my inbox, all the messages are doubled, and clicking on some of
them results in "Unknown error 80470002". Which ones show the error is
irregular. I hat 4 messages in my inbox when I compacted. Both copies of the
first one can be viewed. The first copies of the second and third messages
produce the error. The second copy of the fourth message produces the error. I
selected all 8 messages, deleted them, and saw the "unknown error 80470002"
three times, but they were all successfully deleted
Summary: messages appear double after compacting. → messages appear double after compacting.

Comment 2

18 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
reassigning to navin.
Assignee: bienvenu → naving
(Assignee)

Comment 4

18 years ago
I checked in fix for 68875 on 3/22. reporter, did you notice the problem 
on build from 3/24 onwards. 
(Reporter)

Comment 5

18 years ago
When using build ID:2001032319 after emptying Trash, deleting one message from
Sent, compacting folders the system crashed. After restarting Sent seems to be
okay.
(Reporter)

Comment 6

18 years ago
But lateron compacting Inbox after moving some mails to Trash courses a crash
again and after restarting Mozilla all removed messages appear again and the
latest messages appear double. 
I had to delete all messages again, empty the trash, call compact folders, exit
first and after restarting Mozilla folders seems to be in order.
Unfortunately: bug still exists!

Seems that bug happens when I click on a folder to show the contents directly
after compacting. Do I click to early, i.e., within the compacting process?
(Assignee)

Comment 7

18 years ago
Try to download a new build from 3/26 onwards. Seth checked in his fix on
friday. There was a regression after the performance branch landing. 

Updated

18 years ago
QA Contact: esther → sheelar
(Reporter)

Comment 8

18 years ago
I have used build 2001032720 but the problem still remains. The only difference
I found was that compacting all folders automatically empties my Trash-file.
Again the only remedy was to delete the  msf-files
(Assignee)

Comment 9

18 years ago
I am not able to reproduce this using my debug build from yesterday. It is 
possible that you might have corrupted your inbox. Try to reproduce on another
profile/account or try "Compact this folder" on another folder. 
(Reporter)

Comment 10

18 years ago
I have used "compact all folders". The problems occurs on all folders, not only
Inbox. It seems that not Inbox or any other folder itself is corrupted, but the
corresponding msf-files seems to be.

Can it be a problem having to do with filemanagement of Windows2000?

Comment 11

18 years ago
Similar problem happened to me with previous milestone Moz0.8/W95.
Moz crashed during compacting Inbox. Consequently, I was not able
to delete mails from the Inbox. Actually, the emails were deleted but 
after the next logon they reappeared and were presented twice - real and phantom. 
Only the deleted mails were present twice, the previously undeleted were OK.
The deletion of Inbox.msf did not solved the problem nor additional compacting. 

Later, I found how to solve it:
There existed a compacted copy of the Inbox file (named nstmp.msf, if I recall
it correctly) while the Inbox itself was left uncompacted. Then, I just manually
renamed the correct Inbox and deleted the uncompacted as well as the index file
Inbox.msf. From then on it works fine. This implies that the Inbox could get
corrupt during the compacting procedure and Moz. is not able to recover from
this error.
(Assignee)

Comment 12

18 years ago
looks like this problem is happening only on win2k. CompactFolders on my 
winNT works fine. 

marking duplicate 

*** This bug has been marked as a duplicate of 66795 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 13

18 years ago
verified as dup,
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.