All users were logged out of Bugzilla on October 13th, 2018

Malicious "Video Premium" add-on

RESOLVED DUPLICATE of bug 723753

Status

()

RESOLVED DUPLICATE of bug 723753
7 years ago
3 years ago

People

(Reporter: mhammell, Assigned: jorgev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

25.19 KB, application/octet-stream
Details
(Reporter)

Description

7 years ago
Created attachment 594796 [details]
20120206 youtube2.zip

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

Installed the add-on from vayaina[.]in/video/budado/youtube.xpi


Actual results:

Add-on loads JS to inject http://budado.info/s.js, which injects
http://whos.amung.us/swidget/budado321.gif as an <img> tag and
http://budado.info/e/e.js as a <script> tag

E.js injects an <iframe> pointing to "http://famoso123.info/video/"+video+"/"+servidor+".html";, where video and servidor are provided at runtime.  The iframe is set to cover the webpage the victim is trying to navigate to.



Expected results:

It shouldn't inject an iframe into the user's tab, covering the intended page.
(Assignee)

Comment 1

7 years ago
<em:id>youtb3@youtb3.com</em:id>
Assignee: nobody → jorge
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

7 years ago
This is the same ID as bug 723753. Can you confirm that you can still install this add-on without any warnings?
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 723753
(Reporter)

Comment 3

7 years ago
I installed this one prior to filing the bug, no warnings or blocks popped up.
(Assignee)

Comment 4

7 years ago
I just tried in several versions of Firefox and the block worked correctly. If you can consistently reproduce in a new profile, please let me know via email and we'll figure it out.
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.