Login page lock icon incorrectly broken (padlock with red line)

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Yaron Minsky, Assigned: rpotts (gone))

Tracking

Trunk
mozilla0.9.2
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
The login page for www.virtualbank.com (click on "Log in" to get it) comes up as
unencrypted and unauthenticated, even though netscape 4.7 has it coming up
secure and authenticated.

Comment 1

17 years ago
Reporter what build are you using?  Have you tried downloading the latest
nightly from http://www.mozillazine.org/build_comments/ does that solve the problem?

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 73032 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Reopening. This bug is not the same as bug 73032. The lock icon appears as
mixed, probably due to this line which contains "http:"
<a href="http://www.virtualbank.com"><img border="0"
src="../../images/subpages/cancel.gif" width="53" height="20"></a>

I do not get a warning that I am viewing a page with unencrypted data.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

17 years ago
Setting to new.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
PSM 2.0
Component: Security: Crypto → Client Library
Product: Browser → PSM
Target Milestone: --- → 2.0
Version: other → 2.0

Comment 6

17 years ago
The login link takes us to a non-secure page which then redirects us to a 
secure page.  The docloader is giving nsSecureBrowserUI OnStateChange 
notifications for the non-secure page after it has given us the notifications of 
the redirect to the secure page.  nsSecureBrowserUI then treats these 
incorrect notifications as notifications of insecure content on the secure page.

This is a docloader bug.  Changing component.
Assignee: ddrinan → adamlock
Component: Client Library → Embedding: Docshell
Product: PSM → Browser
QA Contact: junruh → adamlock
Target Milestone: 2.0 → M1
Version: 2.0 → other

Comment 7

17 years ago
*** Bug 77977 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: Login page incorrectly displayed as insecure (padlock with red line) → Login page lock icon incorrectly broken (padlock with red line)

Comment 8

17 years ago
-> rpotts
Assignee: adamlock → rpotts

Comment 9

17 years ago
SPAM: mozilla 0.9 (and M1, and 0.8.1, etc.) has left the building.  please
update the target milestone so we can get a good idea of what's left for 0.9.1.
(Assignee)

Updated

17 years ago
Target Milestone: M1 → mozilla0.9.2

Comment 10

17 years ago
Clicking on the LogIn link at http://www.virtualbank.com/gettingstarted.asp 
seems to be working fine with the latest bits - i get the proper security 
warning dialog and then the lock icon appears on the status bar as expected.

Marking worksforme
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.