Last Comment Bug 724750 - 3D transform backface-visibility has no effect when applied to an element with display:table
: 3D transform backface-visibility has no effect when applied to an element wit...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 10 Branch
: All All
: -- normal (vote)
: mozilla13
Assigned To: Aryeh Gregor (:ayg) (next working March 28-April 26)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-06 19:17 PST by Josh Simmons
Modified: 2012-02-17 05:34 PST (History)
1 user (show)
dao+bmo: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.62 KB, patch)
2012-02-14 10:00 PST, Aryeh Gregor (:ayg) (next working March 28-April 26)
no flags Details | Diff | Splinter Review
Patch v2, now should apply cleanly (2.60 KB, patch)
2012-02-14 10:54 PST, Aryeh Gregor (:ayg) (next working March 28-April 26)
roc: review+
Details | Diff | Splinter Review

Description Josh Simmons 2012-02-06 19:17:09 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.46 Safari/535.11

Steps to reproduce:

Apply 3D transformations to an element with display:table

http://jsfiddle.net/tRW84/2/

Removing display:table from .flip div.face gives the correct behavior.


Actual results:

The back face is still visible on the hover flip.


Expected results:

The back face should hide.
Comment 1 Aryeh Gregor (:ayg) (next working March 28-April 26) 2012-02-14 09:59:53 PST
Minimal test-case:

data:text/html,<!doctype html>
<div style="height:100px;width:100px;background:blue;display:table;
-moz-transform:rotatex(180deg);-moz-backface-visibility:hidden">

This displays a blue square.  Removing "display: table" makes it vanish.  Closely related: bug 722777, bug 726601.
Comment 2 Aryeh Gregor (:ayg) (next working March 28-April 26) 2012-02-14 10:00:13 PST
Created attachment 597068 [details] [diff] [review]
Patch v1
Comment 3 Mozilla RelEng Bot 2012-02-14 10:18:54 PST
Autoland Patchset:
	Patches: 597068
	Branch: mozilla-central => try
Error applying patch 597068 to mozilla-central.
patching file layout/reftests/transform-3d/reftest.list
Hunk #1 FAILED at 26
1 out of 1 hunks FAILED -- saving rejects to file layout/reftests/transform-3d/reftest.list.rej
abort: patch failed to apply

Could not apply and push patchset:
Comment 4 Aryeh Gregor (:ayg) (next working March 28-April 26) 2012-02-14 10:54:06 PST
Created attachment 597092 [details] [diff] [review]
Patch v2, now should apply cleanly

The last version conflicted with one of the patches from bug 721082 that I had applied.  This should apply to mozilla-central.  (I don't know why hg was unwilling to merge automatically, since the differing context was a few lines away . . .)
Comment 5 Mozilla RelEng Bot 2012-02-14 10:58:35 PST
Autoland Patchset:
	Patches: 597092
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=fa9420c4c7dd
Try run started, revision fa9420c4c7dd. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=fa9420c4c7dd
Comment 6 Mozilla RelEng Bot 2012-02-14 16:31:03 PST
Try run for fa9420c4c7dd is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=fa9420c4c7dd
Results (out of 212 total builds):
    exception: 3
    success: 169
    warnings: 21
    failure: 19
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-fa9420c4c7dd
Comment 8 Ed Morley [:emorley] 2012-02-17 05:34:25 PST
https://hg.mozilla.org/mozilla-central/rev/4082936558a4

Note You need to log in before you can comment on or make changes to this bug.