Status

--
blocker
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: tracy, Assigned: alecf)

Tracking

({smoketest})

Trunk
x86
Windows 98
smoketest

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
seen on windows commercial build 2001-03-19-06-mtrunk

-send a message to yourself (just to make sure you have a message there)
-click on get message  
the message is not moved into the message list for in box
(Reporter)

Updated

18 years ago
Keywords: smoketest
I can't reproduce this on Linux with IMAP in a Mozilla tree.

What protocol are you using?

Comment 2

18 years ago
I can't repro this either with IMAP and my Win32 mozilla debug build from this 
morning.

Comment 3

18 years ago
Tracy, what skin are you using?  And, are you using IMAP, POP, or news, or does
it happen on all 3?

Comment 4

18 years ago
Adding hyatt.

Esther ran -console and got:


line 0: uncaught exception: [Exception... "Could not convert JavaScript argumen
t (NULL value can not be used for a C++ reference type) arg 0 [nsIBoxObject.Quer
yInterface]" nsresult: "0x8057000b (NS_ERROR_XPC_BAD_CONVERT_JS_NULL_REF)" loc
ation: "JS frame :: chrome://global/content/outlinerBindings.xml#outliner.outlin
erBoxObject (getter) :: onget :: line 0" data: no]

Incorporate message complete.
Incorporate message complete.
Y'all got mail!
JavaScript error:
line 0: uncaught exception: [Exception... "Could not convert JavaScript argumen
t (NULL value can not be used for a C++ reference type) arg 0 [nsIBoxObject.Quer
yInterface]" nsresult: "0x8057000b (NS_ERROR_XPC_BAD_CONVERT_JS_NULL_REF)" loc
ation: "JS frame :: chrome://global/content/outlinerBindings.xml#outliner.outlin
erBoxObject (getter) :: onget :: line 0" data: no]
(Assignee)

Comment 5

18 years ago
this is because we're missing layout_xul_outliner.xpt in the builds

Comment 6

18 years ago
Unable to view message headers on linux mozilla builds 031908. Tested with
Modern, Classic and Mozillium (restarted after each switch before each mailtest
just in case)

The wristwatch icon sits there and the messages headers do not display. I've
tried clicking through other folders and it appears broken for all IMAP and
local folders.
Tested with RedHat 6.2 in standard 3 pane view.

Also, it appears that the headers are downloaded - the counts are updates and
the biff beep beeps.

I've tested win32 and do not see the problem.

(BTW, Mail on win32 is totally rocking. I've been using Mozilla mail exclusively
since about M11. I have about 7500 imap messages in my Inbox, about 1000 in
other folders and just over 5000 in Trash. I can finally switch between these
folders without going to get a cup of coffee! I can delete hundreds of messages
in the blink of an eye! I can move hundreds of meesages without pegging the CPU
for 4 minutes. I think I'm going to cry)
(Assignee)

Comment 7

18 years ago
Created attachment 28113 [details] [diff] [review]
fix packaging files, mozilla-side
(Assignee)

Comment 8

18 years ago
I checked in, reassigning to me
Assignee: mscott → alecf
(Assignee)

Comment 9

18 years ago
and we're now fixed. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
thanks a lot Alec!

Comment 11

18 years ago
*** Bug 72526 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

18 years ago
verified fixed on windows commercial build 2001-03-20-06-mtrunk
Status: RESOLVED → VERIFIED

Comment 13

18 years ago
*** Bug 72615 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.