Please filter (xbox) spam

RESOLVED DUPLICATE of bug 537105

Status

RESOLVED DUPLICATE of bug 537105
7 years ago
3 years ago

People

(Reporter: arantius, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

I'm getting a lot of spam from AMO (see https://lh3.googleusercontent.com/-5S8e-wbI-nw/TzFBRdswG1I/AAAAAAAADEE/UHrD94i45mk/s800/xbox-spam.png ) like:

Hey, My name is Dane, And your not gonna believe this! LOL. I just got a free Xbox 360 (slim) from this site by completing an offer that only took me about 45 seconds to complete lmfao! I think the systems glitched or something hurry sign up now before they fix it
 http://www.[link truncated]
 (copy and paste that url into your browser) And Trust Me it's not a scam if you don't believe me you can go to my site http://electronicsforfree.webs.com/or ask around for proof on their forums
at http://www.points2shop.com/forums
Must confirm email address

In my email, beacuse someone has filed it as a "review" for an extension I wrote.  Please filter the phrase(s) "your not gonna believe this" / "free Xbox" / "the systems glitched", etc.  Something to stop this extremely common pattern of spam all over the site and my (and plenty of other people's) inbox.



Expected results:

Spam should be blocked.  Akismet perhaps?
You can use the Report Abuse in the user's page to report this spamming. We have been hit pretty hard by spammers in the past few days, but that's something that we can handle manually and goes away eventually.

Attempts to thwart spam were made previously on bug 537105, but that didn't go far.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537105
(Reporter)

Comment 2

7 years ago
It's 2012.  That bug was closed in 2010.  Whatever it did is not working.
Like I said, it didn't go far. However, spamming is something that happens in small, controllable batches and then goes away for extended periods of time.

We have been able to deal with current spammers within a day or less, which at least I think is reasonable.
Duplicate of this bug: 724885
As I understand it, bug 537105 only added a page that tries to detect spam reviews, but relies on admins/editors actually looking at that page, which I don't know if anyone does.

My intention with that bug was that the checks would be done at review submission and not require manual effort, and I still think that's what should be done.
(In reply to Justin Scott [:fligtar] from comment #5)
> As I understand it, bug 537105 only added a page that tries to detect spam
> reviews, but relies on admins/editors actually looking at that page, which I
> don't know if anyone does.

That page doesn't work anymore, apparently, and Abuse Reports are sufficient to let us know about spamming.

> My intention with that bug was that the checks would be done at review
> submission and not require manual effort, and I still think that's what
> should be done.

Should we reopen or start fresh?
(Reporter)

Comment 7

7 years ago
Does "Abuse Reports are sufficient to let us know about spamming" mean that it is intended that spammers successfully send messages into the inbox of various (extension) developers, and then sometime later it gets removed from the site?
(In reply to Anthony Lieuallen from comment #7)
> Does "Abuse Reports are sufficient to let us know about spamming" mean that
> it is intended that spammers successfully send messages into the inbox of
> various (extension) developers, and then sometime later it gets removed from
> the site?

I mean that they are sufficient to replace what page created for bug 537105 did. And yes, what that page did and the Abuse Reports do is let us know after the fact.

I'm as dissatisfied with this solution as you are, but we need to find something that can be implemented within our means. See bug 725022, for example.
(Reporter)

Comment 9

7 years ago
Is using the Akismet API perhaps one of those things?
(In reply to Jorge Villalobos [:jorgev] from comment #6)
> > My intention with that bug was that the checks would be done at review
> > submission and not require manual effort, and I still think that's what
> > should be done.
> 
> Should we reopen or start fresh?

We should file a new bug stating explicitly what checks we want performed before a review is saved.
I filed bug 725370 to track this.
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.