Easy way to copy from console including network info

RESOLVED WONTFIX

Status

DevTools
Console
RESOLVED WONTFIX
7 years ago
12 days ago

People

(Reporter: Kevin Dangoor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
blizzard reports that people are taking screenshots of network panel output to help troubleshoot network problems (think of resources being served from CDNs). They would like a way to copy from the Web Console and paste the results including network panel info. One possibility would be that copy with network info would put HAR formatted data on the clipboard, but that doesn't need to be the solution. We should see what options the other tools provide (if any)

Comment 1

7 years ago
I think we should present formatted plain-text instead of the current html/XUL UI.

We can use Orion for that, with a dedicated lexer.

For example, this is what I manage to get with Vim: http://i.imgur.com/X8g1Q.png

Imagine this in a doorhanger, or inline in the console, or in a panel (like we have today).
It could be read-only.

Comment 2

6 years ago
This has been fairly frustrating with the TreeStatus work, trying to copy/paste headers text out only to get linebreaks missing and spurious ones inserted :-(
OS: Mac OS X → All
Hardware: x86 → All
We will remove the network panel from the web console, see bug 861335.

The new netmonitor (bug 855544) will cover the requests made in this bug. See bug 859133, bug 862019 and bug 862020. We also have a bug open about allowing export to HAR that I can't find now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(In reply to Mihai Sucan [:msucan] from comment #3)

> We also have a bug open about
> allowing export to HAR that I can't find now.

Bug 859058 and bug 859059.

Updated

5 years ago
Duplicate of this bug: 850330

Updated

12 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.