Thunderbird 10 unable to connect to mail server with Avast 6 AV installed

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
6 years ago

People

(Reporter: urizan, Unassigned)

Tracking

10 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

allowed thunderbird to upgrade automatically after installing Avast 6 AV


Actual results:

Thunderbird stopped connecting to all mail servers


Expected results:

Thunderbird should have been able to connect to all of the mail servers.
well Avast is blocking the connections because Thunderbird changed. If you re-enable Thunderbird in Avast are things working ?
(Reporter)

Comment 2

7 years ago
I was unable to find those settings in the Avast AV GUI - do you know if there is a specific file I should edit for Thunderbird?
(In reply to M from comment #2)
> I was unable to find those settings in the Avast AV GUI - do you know if
> there is a specific file I should edit for Thunderbird?

No :(
(Reporter)

Comment 4

7 years ago
An error occurred sending mail: The mail server sent an incorrect greeting:  Cannot connect to SMTP server 77.232.xx.xx (77.232.zz.zz:25), connect timeout.

Avast is actually telling me its popup to turn off tls in the mail client and that it will use its own tls to scan mail.  I think I want to disable the email scanning by Avast instead.
(Reporter)

Comment 5

7 years ago
Avast 6 real time Mail Scanner disabled permanently and still unable to send or receive.  Thunderbird 8 continues to work fine on my other computer without Avast 6 AV installed.
(Reporter)

Comment 6

7 years ago
So, I disabled Avast real time Mail Scanner and I am receiving emails again.  Pretty sure its back to normal now.  Just check your AV settings if Thunderbird suddenly stops working and disable your AVs Mail Scanner to see if it works.
(In reply to M from comment #4)
> An error occurred sending mail: The mail server sent an incorrect greeting: 
> Cannot connect to SMTP server 77.232.xx.xx (77.232.zz.zz:25), connect
> timeout.
> Avast is actually telling me its popup to turn off tls in the mail client
> and that it will use its own tls to scan mail.

Avast has three kinds of mail scanning.
(1) Mail proxy type for non-SSL connection.
    Obsoleted. Replaced by (2). (perhaps still available for compatibility)
    Mail client, server=localhost,port=NN <-> localhost:NN opened by Avast!.
    Avast! accesses server.
(2) Port scan type for non-SSL connection.
    Mail client, server=actual-server,port=actual-port
    Avast! hooks server access by mail client.
(3) SSL tunnel like hooking for SSL connection. New from Avast! 5.
    Called "SSL account" in mail shield setting of Avast!.
    Mail client : server=actual server&userid, port=non-SSL port(25, ...),
                  No secure connection(not SSL/TLS nor STARTTLS)
    At Avast!, define actual access type :
      server=actual-server or part of server domain, 
      connection security type, actual-port for SSL/TLS or StartTLS
    Avast! hooks Tb's access, and accesses server via SSL or using STARTTLS.

What is you setting?
Is StartTLS used for "77.232.zz.zz:25" in Tb's Server Settings?
Do you enable mail scanner of (2) for the connection?
If you need mail scan for server which uses SSL/TLS or STARTTLS(name in Tb's setting), you need to use (3) and select SSL or TLS in Avast! setting(perhaps TLS in Avast! is STARTTLS in Tb, but I'm not sure.)

> Expected results:
> Thunderbird should have been able to connect to all of the mail servers.

Because Avast! is also an indepndent software, you need to read manual or help of Avast! well before you start to use application software called Avast!.
Please don't use B.M.O as support forum of help forum. B.M.O is place to report Tb's actual bugs to developers.

Comment 8

7 years ago
M,  questions for you in comment 7

Comment 9

6 years ago
reporter, do you still see this problem when using a current version?
Component: General → Untriaged
Whiteboard: [closeme 2012-12-10]

Comment 10

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-12-10]
You need to log in before you can comment on or make changes to this bug.