jQuery sortable and FF 10, drags but doesn't drop

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: DC Dalton, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by Firebug])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

Using existing code (over a year old) that worked properly a 'draggable' list using jQuery sortable. Using jQuery 1.6.2 and UI 1.8.2 (also tried the original UI 1.8.16 which the original code was built on)


Actual results:

You can drag items but they will not 'drop', they are 'stuck' to the cursor, only way to get rid of it is to close the browser or refresh the page


Expected results:

element should drop. I have tested the code (again this is year old code) in FF 9, IE 8, Chrome and they all work

Comment 1

7 years ago
Please provide a public URL or reduced test case that exhibits this issue.

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

Any errors in the error console?
(Reporter)

Comment 2

7 years ago
I pulled all the code out of the admin panel and striped it down to just this and it still does it, see here: http://aoops.com/drag-test.html

Works as expected in safe mode. BTW, I also tested some code on another site I built 6 months ago that uses draggable and droppable a bit, experienced the same issue.

Quite a few errors in firebug window, all relating to jQuery itself (all of these reference the jQuery files, not my code):

No elements found with the selector "*"

No elements were found with the selector ":data(sortable-item)"

You've called bind ([object Arguments]) more than once on the same object (mouseup:sortable, function .... )

No elements found with the selector 'undefined'

You've called css ([object Arguments]) more than once on the same jQuery object (Collection: [ li#iistItem_3.ui-sortable-helper])

No elements found with the selector ":data(droppable)"

that's about it for now

Comment 3

7 years ago
(In reply to DC Dalton from comment #2)
> Works as expected in safe mode. BTW, I also tested some code on another site

If it works in Safe Mode then there is likely an extension causing the issue. See http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes
(Reporter)

Comment 4

7 years ago
Well sir you would be 100% right, it is Firebug 1.8.1 causing it. The second I disable it and restart the problem is gone.

Thanks

Updated

7 years ago
Component: Untriaged → Extension Compatibility
QA Contact: untriaged → extension.compatibility
Whiteboard: [Caused by Firebug]

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.