Last Comment Bug 724966 - All menu is closed without intending after open submenu and move mouse pointer
: All menu is closed without intending after open submenu and move mouse pointer
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: 13 Branch
: x86 Linux
: -- normal (vote)
: mozilla13
Assigned To: Karl Tomlinson (ni?:karlt)
:
Mentors:
: 725181 (view as bug list)
Depends on: 725685 726410 726443
Blocks: 500081 724967
  Show dependency treegraph
 
Reported: 2012-02-07 09:38 PST by Alice0775 White
Modified: 2012-02-12 16:19 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
make sure to set sRetryGrabTime for retrying grabs (1.76 KB, patch)
2012-02-07 12:26 PST, Karl Tomlinson (ni?:karlt)
roc: review+
Details | Diff | Review

Description Alice0775 White 2012-02-07 09:38:07 PST
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/8f1b1574e4b0
Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/20120207 Firefox/13.0a1 ID:20120207035004

In last m-c hourly.
A sub menu is closed without intending after open submenu and move pointer

Reproducible: Always

Steps to Reproduce:
1. Dtart Firefox with new profile
2. Click menu in Menu bar
3. Mouse move[1] on a menu(like a folder) and Wait until the sub menu opens
4. Mouse move[1] to upper-ward/lower-ward --- all menu unexpectedly closed

note:[1]not drag

Actual Results:
  All menu is closed
  
Expected Results:
  Only the submenu should be closed

Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/841b4395aa66
Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/20120206 Firefox/13.0a1 ID:20120206175103
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/050334f9128c
Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/20120206 Firefox/13.0a1 ID:20120206181401
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=841b4395aa66&tochange=050334f9128c

In local build:
last good ca19aff687a1
first bad 050334f9128c
Triggered by:
050334f9128c	Karl Tomlinson — b=500081 use a timestamp when grabbing the pointer and generate timestamps for drags in the same way r=roc
Comment 1 Karl Tomlinson (ni?:karlt) 2012-02-07 12:26:43 PST
Created attachment 595130 [details] [diff] [review]
make sure to set sRetryGrabTime for retrying grabs

I missed an early return setting mRetryPointerGrab = true.
Comment 2 Karl Tomlinson (ni?:karlt) 2012-02-07 18:24:22 PST
*** Bug 725181 has been marked as a duplicate of this bug. ***
Comment 3 Karl Tomlinson (ni?:karlt) 2012-02-07 18:37:24 PST
https://hg.mozilla.org/mozilla-central/rev/b45785802731

Note You need to log in before you can comment on or make changes to this bug.