Add ability for admins to block IP addresses from writing reviews

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: cvan, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
We should create a tool for editors/admins that allows them to blocklist users by an IP address (or range).

We lost the war on spam (bug 537105). We've been getting rampant spam from different user accounts (bug 724882 is one instance of this). This should bring us closer to fending off the spam bullies.
please check IPs against our list of Mozilla-internal IPs. I can already see this going badly
Up until now the (very rare) IP block requests have been at the firewall, not in our software.  This raises management and caching questions not to mention we have to actually implement it.  Wontfixing for now.  We can revisit when we run out of bugs but until now it hasn't been a problem.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
It's entirely reasonable for us to block IPs from writing reviews. It's less important than the automated checks we should put in place, but if we have evidence that we have repeat spammers from the same IP, we should implement this.

Jorge, have we seen spam coming from multiple accounts with the same IP?
Summary: Add ability for admins to blocklist users by IP address → Add ability for admins to block IP addresses from writing reviews
The recent spam problem is being caused by a single individual, since it is always the same account with the same name (which I repeatedly delete). I haven't checked if the IP address is always the same, but there's no reason to suspect it isn't.
Blocks: 725370
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.